Can’t access PUBLIC folder on MyBook WD II

thek1907  , if you are using IE9 please visit the link below:

Thanks :smiley:

My question was:

I have a problem. Suddenly I do not have access to PUBLIC folder on my MyBook WD II.

It says that \Hjem\public is not accessible.

I have tried to access the NAS server from another computer
I have tried to reset the NAS server
I have tried to reset my router (Dlink dir-615)
I have tried to take ownship over the folder
Nothing has helped me so far.

The weird part is that I can create another folder on the NAS server, and this new folder works fine. When I right click the folder, I have a Security tab, but I do not have it on the PUBLIC folder.

In the web-backend of the NAS server, the PUBLIC folder is set to Full Access to Everyone.

Any hints on how to fix this problem?

Same problem here. Been running fine for months  but  today cant access Public folder. Running Mac 10.6.7 with MBWD II and latest firmware 1.2.6.

Public is seen by the Mac but won’t mount … just sits there saying “connecting to afp:// etc”.

Can connect to and mount Download folder, can create and mount new shares, can ssh into Public and access subfolders and files etc. No errors reported anywhere in MB or Mac. 

Any ideas would be much appreciated. Thanks, Roman

Some progress …

Enabled NFS on the MBWD II and mounted Public succesfully with the terminal command

mount_nfs    /Volumes/Public

What I see is a bunch of  /2e… directories  in the Public folder as well as the usual Shared Music, Pictures, Videos folders.

Before I go any further I’m gonna do a backup cos at least can access Public from the Mac. Hope this may help someone.

Cheers, Roman


After much googling found this;wap2

Since I dont have filebuddy did SSH into MBWD as root and in directory /shares/Public just deleted the .AppleDB and .Appledesktop files and now all ok :slight_smile:

Obviously this is Mac only but may be a clue to those on pc’s with similar issues.

NB. Take note of what the link says re the .AppleDouble file - do not delete this!!!

Cheers, Roman