Can see MyBook but not connect or access files?

If you’ve had this problem, this worked for me.

  1. In Finder, go to Go --> Connect to Server.
  2. For the server address, type in smb://MyBookWorld/Public , where “MyBookWorld” is the name of your network drive.
  3. Enter your username and password if prompted or when you click to connect.
  4. That should get you acces to the PUBLIC folder and more

Only problem I now have is that when I try to copy any files to another storage device I keep getting an error code -50 ??

Seems I can copy files but not Folders - which is a real pain given how many files and folders there are!

Also looks like some of the folders have been given strange numerical replacement names??

Fix anyone??

Can you please provide more information about your issue.

In the subject you are saying that you are not able to connect. However, in the post you are saying that the problem is basically when you try to copy folders from the drive to a different location.

Can you please provide me the model number of drive that you are using and where is the drive being connected.

I wasn’t able to connect until I found the stated way to do so. I posted this for others who might have had the same issue.

Copying all my folders and files to another drive from the MyBook results in error code -50

Whatever caused the MyBook to not be accessible (without using the Go to Server method) has also resulted in renaming many files that had characters other than letters or numbers with random names made up of letters and numbers?

After a long search a copying workaround was found.

This means using the Apple Terminal application and using a copy command cp -R , selecting the source folder and then selecting the new destination folder. It takes a while and copies all the files without the error code -50 happening.

Whilst Terminal is working it does show .Appledouble Invalid Arguments but the files all copy fine.

Apart form the massive time loss this has all caused, the other pain is having to go through all folders checking for files and folders that have been randomly renamed.

I just experienced the same problem with a Buffalo NAS - Error -50.

Upon looking at tthe folders that would not copy, I found they all contained a folder named “.AppleDouble” - from the terminal I used the ‘find’ command with ‘rm -rf’ on the results; now all the folders from which I’ve removed the “.AppleDouble” folder copy correctly, and show up with the proper icon. Before the removal, they all showed with a generic icon for the appropriate application. I’m sure there are better arguments to ‘find’ and ‘rm’ than I used, and I will look at that further.

I’m connecting to the NAS with AFP.  I haven’t tried connecting with SMB yet, but will check that out, and research further details. Something creates .AppleDouble, and something objects to its presence.

Also, it would be nice if someone could suggest a solution that doesn’t use the terminal. Spotlight might help, but doesn’t offer some of the options of the classic Find File function.