Can see and access My Book but Discovery won't find it

The My Book Live 2TB drive is connected to our work network through a wired router. I can access the Dashboard through the browser. I can see it on the network and access it like any remote drive. But, My Book Live Discovery will NOT see it so I can install the software on my computer.
I’m using a Toshiba Satellite L675 with Windows 7. Network discovery is on (must be because I can see and access the drive through the network just fine). Why won’t the Discovery see it during installation? I have been through every suggestion in the Knowledge Base and FAQ and just can’t seem to find it.
Firmware was updated in hopes of fixing the problem : nope.

The issue might be related to a firewall, however WD Discovery has been discontinued; try using WD Link.

Tried WD Link and still not able to discover drive so software can be installed.  Can access dashboard with browser, can access it through network, but cannot discover it to install software. 

Even when I am currently accessing the dashboard through the browser AND accessing the drive through the network the discovery software will not find the drive.

Also … all UPnP Network Discovery traffic is allowed in the firewall.