Can not RESTORE from my Passport 1TB

I mistakenly posted this on the External Drive Forum instead of here.
When I plug in my Passport 1TB to my HP Laptop, the Passport appears as a Device, but the application screen does not appear: i.e. Backup, Restore etc. I want to restore the last backup that I made before the WIN10 crash, and I can see backup files on the Passport, but I can not access them with the Restore command because the screen that offers BACKUP and RESTORE never appears. Perhaps: If I run the original “setup or install” file for the Passport, this application screen would become available. I can not find any “setup or install” file either on my laptop or the Western Digital web page. S/N WX21A299Z9L0 P/N WDBYVG0010BBK-0B

To install WD Backup, please follow this KBA: https://support-en.wd.com/app/answers/detail/a_id/8198

And, to restore: https://support-en.wd.com/app/answers/detail/a_id/8636

Sorry Jonty.S: No problem downloading and running the files. But when I clicked RESTORE, the answer was: Your files will be restored from the device or cloud you select…the answer was: No backup targets found. I repeated everything 2 times and with same result. One other comment. I plugged this Passport into an old HP laptop with WIN7 Pro and it recognized the Passport. It seems to me that there is a problem with WIN10 on the newer HP laptop. Perhaps this occurred when it crashed. The problem continues when I plug the Passport into the WIN10 HP laptop. The only response is a directory screen showing 2 items in the Passport. It does not show the opening Program screen with the Backup, Restore etc choices.

A more simple way of explaining my problem: When I plug in the Passport 1TB into the USB port of my HP Laptop with WIN10, I do not get the Backup, Restore Program home page. This is all that appears. How can I make it work properly?

Progress?? I found and ran WD_SMARTWARE_INSTSALLER_2.4.21.ZIP
I now can click on Smartware on the WIN10 HP laptop and the Sartware Screen opens up. The lefthand box “Backup Source” shows the HP Laptop. BUT, the “Backup Target” box is blank. Also the function line shows: Home, Settings, Help (lit up) but the Backup and Retrieve boxes are not lit up. The Passport shows up in the Laptop’s “Device” page, so it recognized. I was not able to get the Passport recognized in the previous Smartware setup operation.

Another contributor called: “go140point6” offered a suggestion in a different post titled: No Backup Target Found Using WD Backup. I diligently followed each step, even changing a line in the Registry. The Backup Target then appeared and I Restored the files. I decided then to test the Backup function. The result was No Target. So, I repeated all of the steps, Reloading WD Backup. I could then Backup. So I tried the Restore again and the error was No Target. A continuing Loop. I can’t keep this up. Sorry WD Passport. Hello Segate. Case closed.