Can not open items in interface

I have been using my passport with no problem. Now I went to look for the User Manual to see how can I use CCleaner to clean it up, but I can’t open the tools in the Interface. I can’t even open the license agreement.

When I click User Manual it says that I need Adobe Reader to open the file. I click Adobe Reader Installer and I get a message that says they can’t locate this file: FW_windows_tools/adobe/eng/set exe. The interface has worked fine before, so I don’t know what could have happened to the file.

I have the latest version of Adobe Reader any way in my XP desktop, and also in my Windows 8 Laptop, but I get the same message in both computers.

How can I get my interface to work, and how can I use Ccleaner to clean the drive. If I am missing that file, how do I get the file they say I am missing, how can I get it? 

Edie M

If you have already run Ccleaner on your OC it may have remove something important. You need to use care when running any of these registry cleaner products. When I run it I use the default settings and save when the option pops up before deleting. I use the free version and there is no option to clean other drives. I doubt it would do much anyway it cleans up temp files and registry items left behind when installing, updating, and uninstalling software.