Can not delete

I have some movies stored on the public share of the WD Live device that i can not delete.  When i delete it says that the file is still in use.  I have tried a reboot of the device and then to delete again, but this has not worked.

Has anyone else had an issue like this? I cant delete the file… Help!!

i also am unable to delete files from the public share since the last firmware update.

Provide a bit more information.

What OS? what folders,what were you doing at the time you copied the file (what did you copy the file with)?

OS X Lion.  I copied a batch of videos from my internal hardisk onto mbl/public/sharevideo/subfolder.  I then went about renaming the videos.  At one point, I could no longer rename the videos.  I then renamed the original video on my main hard drive, and copied it back into the mbl subfolder.  I then tried to delete the corresponding video since it meant i had now had two copies – 1 with the correct name and one without.  I was unable to delete it, and investigation showed that I could no longer delete (or rename) any files from the MBL. I can still copy files TO the MBL without issue.

i copied the files simply by dragging and dropping.  all the permissions are correct and i am logged as an administrator. 

Im having the same issue with a video file in the shared video folder, Windows XP.


Since I had only added the one file to the drive, I decided to try a factory reset (destroy data). Well I started it yesterday, not sure how many hours but its been all day and night, and its only 25%-30% complete. (guessing based on bar). A little rediculas if you ask me.