Can NOT delete files on NAS White led 1.5TB - TWONKY Problem


#1

Hi,
I have a folder called Shared Videos on Public and  I found  that I can’t modify it. I can add new files but can NOT delete or rename. All I get is : You require permission from Unix User\Nobody to make changes to this file.
Why is that?

UPDATE: Rebooting didn’t help. Still have this Unix user/nobody issue.

UPDATE 2: I moved the files back to internal HDD, restored the NAS to initial condition.
When on hdd, the files above were modifiable.

UPDATE 3: I noticed that I lose all permissions anly after I ask TWONKY server to search for media.
I restored the NAS again to initial condition and all worked well. Now I don’t touch twonky.

Do you know how to kill/remove/uninstall twonky server ?


#2

I’m having similar problems with a World Edition II (2x1TB) system.  I can successfully copy files to folders in the Public share or a share that I’ve created separately through the web interface.  But after that, I cannot delete the files using the Snow Leopard finder.  I can only delete files through the terminal.

Any attempt to delete a file through the Finder yields an error message similar to the following:

The operation can’t be completed because the item “myfile.jpg” is in use.

Anybody else having this problem or know how to resolve it?  

-Aaron


#3

Update from previous post…

Instead of connecting to the NAS through the Shared server list in the Finder sidebar, I connected using the “Go -> Connect to Server” menu in the Finder instead, but this time accessing the share through SMB instead of AFP.  

After I connected (either as Guest or Admin) using SMB I was able to now delete files.  So to me, it looks like there is a bug with the AFP connection to this device that limits the permissions on the files or something else wonky.

FYI, I’m using firmware 01.01.16.

-Aaron


#4

Hi Aaron,

I understand that you are not a windows user.
you wrote:

areichman wrote:

After I connected (either as Guest or Admin) using SMB I was able to now delete files.  So to me, it looks like there is a bug with the AFP connection to this device that limits the permissions on the files or something else wonky.

 

FYI, I’m using firmware 01.01.16.

 

-Aaron

 

Now, SMB and CIFS fow two names for the same protocol.

Doesn’t the connection between NAS and windows works on CIFS by default?
Another question is how did you access the NAS via terminal? I can’t do it via telnet.
I use firmware 01.01.16.


#5

Are you running the latest firmware? If you go to Advanced Mode -> Update, what version does it show? If you click “Check For New Firmware,” does it report that an update is available?


#6

Sure, I wrote that I use 01.01.16 and it seems to be the latest since no updates available.


#7

I too am having this problem…  I saved some files to the root of the Public/Shared Videos directory.  When I went to move them I was given the same error.  I don’t see how to turn off Twony so I removed the Shared Videos directory from its grasp.  Still no luck.

I ended up FTP-ing into the box using WINSCP using my admin credentials and one by one I was able to delete the files at the root of the Shared Videos folder.  It seems that anything in a sub-folder I can delete.


#8

In an earlier update, I claimed I had success connecting via SMB/CIFS instead of using AFP from Snow Leopard.  However, that success must have been short lived, since I’m now getting the same error even with SMB.  So I’m still without a clue on how to resolve this issue, save for a firmware update that I’m hoping will arrive to fix the issue.  Until then, I can only delete using the Terminal app from Snow Leopard.  For those Windows users that asked how I did this, remember that OS X is a Unix OS so I can use the command line to access the share.  I am not using telnet or anything.  Same would hold for any Linux users.

If there isn’t a resolution to this soon, I’ll probably end up returning the unit to Amazon.  


#9

I forgot to note…I can delete the files if I delete the whole folder though, which is odd.  So the files are definitely not “in use” or the folder delete would fail.  I just can’t delete files directly by selecting them in the subfolders.


#10

This is what I did, it worked for me:

  1. Moved the files back to PC/MAC, they all came back to normal.

  2. Restored the NAS to initial condition (no data, no settings). There is such an option in ‘advanced’ (If I remember correctly).

  3. Moved the files back to NAS.

  4. Didn’t touch twonky, didn’t even enter it.

  5. Left all shared folders empty just in case.

Everything works so far.


#11

I’ve given up on this thing.  I tried Jacob’s approach and reset everything to factory defaults.  That worked for about a day and now I’m back to not being able to delete anything.

I don’t know what else to do and WD Support has responded to my request for help after more than a week.  I’m going to try to return this to Amazon in exchange for something else.


#12

Sorry to hear that.
Did it return to this condition by itself?


#13

Public is the default share on the MyBook World Edition. Inside Public there are three folders

1> Shared Music

2> Shared Pictures

3> Shared Videos.

These shares cannot be modified nor it can be deleted as they are on the firmware of the drive itself.

Most of the times, the files that are copied on the drive cannot be deleted. This can be due to the Firmware issue. Reset the drive, i,e. unplug the Ethernet cable from the unit and with the Unit Power ON, hold down the Reset button for atleast 40Sec, then reconnect the LAN cable back to the device. Wait for 2-minutes and then try to delete the data.

It should work.


#14

Got an answer from WD support as follows:

“I apologize for the inconvenience; It appears your drive is defective, I would suggest replacing it.
Please see below for your data recovery and drive replacement options.”

As I wrote few posts ago, I stopped using all SHARED folders and leave them all empty. Is was my solution to the problem.


#15

Jacob, I ran into a similar problem trying to delete a couple of folders from my Public/Shared Music folder, stating I needed permissions granted by Unix User/root to perform the required action.  I found a way around it hopefully it may work for you:

Go to the configuration of the drive

Enable FTP

Open a browser / explorer and navigate to:  ftp://admin@

When prompted enter the password for your admin account for the Network Storage Manager

Navigate to the folders you require to delete and attempt to delete

I had tried a number of times to figure this problem out and the approach above finally worked for me.


#16

Hi, since I saw your post I’ve been trying to restore the conditions in which I have the permissions problem.
No luck so far.

When I had the problem, couldn’t solve it. When I want to restore the problem, can’t get it done.
I think I’ll consult the WD Mystery department.

Thanks ViscountUK. I’ll report back as soon as I’ll get it (not) working.


#17

Surely WD can’t assume this problem is with the hardware and have everyone return their unit.  I received my unit back in Dec and immediately updated the firmware to the latest version and have the problem.  Did anyone have this problem with earlier firmware versions?

If someone from WD is monitoring this discussion can you please advise when a firmware solution will be available?


#18

Gee, I thought I was the only one having this problem…except mine is on the 2TB  MyBookWorld White LED drive.  My issue only affects MS Office Suite files.  They come back as “Open by another user” when I try to access them via the network…funny though, I can access them via MioNet with no problem.

The MioNet Tech I contacted also said it was a hardware problem…If so, that is going to be a Toyota-size return problem for WD…


#19

I have the same problem. Can’t access twonky, can’t access shared folders, can’t update firmware, can’t find NAS via WD discovery; Can’t find Upnp server via network player!


#20

I’m experiencing the same problems with the three shared folders. I copied content into the folders and now i can’t delet it anymore. This only concerns files and not folders. All folders with data I can delete, move and update. For al files I get the error message that I need permission from Unix user/nobody.

I’m running Win7 and the WD Mybook 1TB World Edition with Firmware upto date. I dont think its a Windows problem anyway. Its rather a Twonky or Firmware problem from WD.

Edit: No deleting possible over FTP Server.

I also contacted the support center. Lets see what their solution to resolve this problem is.