Can not connect to network

I have the WD TV Live Plus system and bought a D-Link Xtreme N Dual Band USB Adapter to connect it to my network so I can view streaming videos.  However when I connect it, my WD system is not recognizing it is there and won’t connect to my network.  I tried doing a manual setup of the network and still unable to get it to work.  Anyone have any ideas as to how to get it to even recognize it?

Save yourself the aggrivation and purchase a player manufactured by another company. The WD TV Plus does not connect reliably to a network, period. The firmware is beta and has not been updated to fix bugs in a year and a half. This unit is buggy and not supported.

Try a Boxee Box, it actually works reliably.

Are you seeing the WIRELESS setup menu?   If NO:

You need to use an approved WiFi adapter.

If your adapter matches the list, but it’s still not working (and you have the latest firmware in the WDTV) then the chipset on the adapter may have changed and it’s a different version that WD tested.

If you cannot find an adapter that is on the list, then you can:

1- use Homeplug AV adapters

2- Use a WiFi “bridge” or extender.

sadly it is one on the list, and still not showing the wired/wireless option, just goes straight to automatic/manual set up guess I get to return this one too…