Can not access mycloud from one windows machine on my LAN


I have a pretty strange problem.
I can’t access or see mycloud on my thinkpad which is connected to the same LAN.

Everything else is working.
So on my thinkpad I can contact all other devices on my LAN.
All other devices on my LAN can contact my mycloud harddisk.

When speaking about access / contact - I mean in the first place
a/ pinging the IP address of mycloud hard drive
b/ entering the IP address of mycloud hard drive in chrome browser

When I try to ping from thinkpad to the mycloud IP address I get the following error:


Pinging with 32 bytes of data:
General failure.
General failure.
General failure.
General failure.

Ping statistics for
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),


Note that pinging to any other device in my LAN is working fine. It is only the mycloud device that gives a problem.
If I ping to the mycloud device using another windows machine in my network it is also working fine.

So it is a specific configuration of my thinkpad (windows 7) that is incompatible with mycloud device.

Thanks for any help.


If all the devices are within the same work-group, try resetting the unit and check the firewall settings on the router to make sure that is not blocking that specific connection.

a “General Failure” of ping is normally firewall related (router or think pad)

What is the current IP address of your thinkpad?

It is indeed firewall related.
So when I disable symantec endpoint protection firewall on my thinkpad then I could ping to (= IP address of mycloud device).

When looking at symantec “Traffic Log - Network Threat Protection Logs”: it says that Rule “Block IP Addresses” is applied twice when pinging to

I had hoped that I could easily identify and disable the respective rule. But after quite some time I have still not figured out how I can do that.


This video may help…

Configuring endpoint firewall rules

You might be able to get around the firewall by adding a rule ALLOWING outbound connections to your NAS IP address.

Thanks for the response … but on my thinkpad I don’t have the same application for editing the firewall rules. The screenshot below shows my firewall rules. I have edited some of them but without any effect. It is also not clear to me which of those rules are blocking the ping to

No ports are required for Ping as it uses icmp packets.

It needs to allow icmp ‘echo-request’ (type 8) packets out and icmp ‘echo-reply’ (type 0) packets in.

Have you tried adding a firewall rule to allow all packets in and out to your MyClouds IP address , just to see if it works?

I have tried adding a rule that allows all packets in and out to myclouds IP address without any success.

FYI in the traffic log of symantec (see here below) you can see that it is blocking the IP address.

I have changed the static IP address from my mycloud device from to and it is working now.

I am happy with the work around.

Thanks Wullailhut, SBrown and ERmorel for the support.
After all it was not a WD issue but a symantec issue.

The rule it’s using is shown in the log ‘block ip addresses’ " there must be one named that you can disable or edit.