Can not access information in my WD Passport when I plug it in a PC with windows XP

I used to use my WD Passport with a Laptop with Windows 7, but since my laptop stopped working I need to access the files in my hard drive with a PC that has Windows XP. At beggining when I plugged it even though it recognized it, the installation wizard said It could find the driver/controller and couldnt install it correctly. Then I checked out some forums and found you can download the driver so I went on and did that, and even though once I install that, it seemed like it solved the problem when I wanted to access the unit, it gave me a message that said: “This unit has no format, would you like to format it now?” and it didnt show me any of the previous data I had there at all. I´ve also tried changing the drive´s letter which I read could be a solution, but still nothing, and I´ve also read that It could be a power problem but My WD Passport is plug and play so I cant plug the power externally. Any help will be appreciated, thank you in advance!


I recommend that you try on a desktop computer if possible and change the USB cord if you have another one. If the issue remains then a data recovery software will be a good choice.