Can I throw my book world edition 2tb in the trash can?

After many years I rediscovered my ‘my book world edition’ which I used in a previous life. I want to connect it now to my Mac, after three days of searching on the internet (no more support from WD, MAC doesn’t recognise) I am desperate. Can I put this in the trash can? If I ever can re-animate this drive, I would connect it to a WD EX2 ultra that I want to purchase. Is there anyone who can give me a reasonable answer?

Have you looked at the WD Legacy product page for your version of the My Book World Edition? Have you read the user manual for your version to set it up? Or to possibly reset it?

https://support-en.wd.com/app/products/product-detail/p/220

It appears the My Book World Edition is some sort of basic NAS. Not sure how you plan on connecting it to a WD EX2 Ultra if that’s the case. If the My Book World can function as a basic USB hard drive then it could be attached to the My Cloud EX2 Ultra’s USB port. But if it’s like many other WD NAS devices the USB port on the device is ONLY for attaching other external USB hard drives to it. It is not for connecting it to a computer or NAS and using it like an external USB hard drive.

See the dedicated EX2 subforum as this subforum, My Cloud, generally discusses a different device, the single bay/single drive My Cloud.

https://community.wd.com/c/network-attached-storage/wd-my-cloud-ex2/109

Also see the WD legacy products My Book Live subforum.

https://community.wd.com/c/wd-legacy-products/my-book-live/50

Hi Bennor, thanks for your reply. Going to the WD legacy product page, every possibility leads to:
Support for these products are no longer available. For assistance ask the WD community. Seems that WD is very contented with the community…
I read the user manual several times. Problem is that my mac doesn’t recognise the MyBook. So there is no access to MyBook. The link to my-book-live makes me even more assured that my MyBook is ready to deliver to the trashcan, there are more members with similar issues, simply because WD does not support those devices anymore with updates.
My only simple thought now is… What will happen after five years, when I buy a new NAS storage, like EX2 Ultra… support will also be stopped by WD?
Thank you anyway for your advice!

Have you connected using, a Ethernet cable the My Book world edition to a network router using the thse network port on the back of the drive?

If so does the network router administration page show an IP being assigned to the My Book world edition?

If a IP address is being assigned the try connecting to that address with Mac Finder.

It should be noted the EX2 Ultra was introduced in late 2015.

That is what I tried early this morning. The MyBookWorld can only be connected to a router and I checked the IP, then tried to go inside through the browser. Nothing, it will just be stuck. Also in Finder going to network, nothing…
I was wondering if I disassemble the Mybook, can I still use the drive? 2TB.
And yes, thanks for mentioning. EX2 Ultra might be too old already also. Soon to be ‘not supported’ anymore, for commercial reasons…

Have you performed a reset using the reset button on the My Book World Edition? May have to press and hold the reset button for 4 or more seconds. Are there any LED lights on the front of the My Book World? If so what is the color. Could be the unit is dead and that’s why it’s not showing up on your Mac. Or if one is running security software on their Mac it is possible that software is blocking access to the My Book World if that device is obtaining a network IP address.

While I don’t have a Mac, it appears one would locate the My Book World by opening the Finder, locating the Shared list, one may have to click All, then they should see MyBookWorld listed. This assumes one has their Mac connected to the same router the MyBookWorld is connected to.

We end users likely won’t know when WD will move the EX2 Ultra to End of Life statutes like they’ve done to some other units. But the EX2 Ultra appears to be a very popular device that is being sold in numerous stores/retailers. As such doubt it will be retired any time soon by WD.

Assuming the hard drive within the My Cloud Live still works one could “shuck” the drive from the enclosure and check it on a computer using a powered SATA to USB adapter or a spare SATA port on the PC.

Can’t speak to the Mac OS but Windows has had great difficulties recognizing network drives for the last year or so. Probably several issues but one is SMB setting - again, don’t know if the Mac OS has the same issues.

But in your case, you have to determine if there’s something wrong with the drive, something wrong with the network, or something wrong with the Mac OS.

Seems a shame to break open the NAS just to get a 2TB HDD (which may be the problem) and then throw away the rest. Honestly, I wouldn’t get too bogged down with “is it going to be EOL soon or not”. Once the warranty expires (usually 12 months) you’re on your own with any manufacturers product. Just be thankful you don’t own Netgear stuff - 1 year warranty but after 90 days, you don’t get any tech support to determine if you have a warranty issue - round and round in circles - pay for tech support after 90 days so you can get the warranty honored!

Good luck!

The Windows difficulties are due to Microsoft deciding, through a update patch, to disable SMB1.0/CIFS for security reasons. That option is likewise disabled in new PC’s that ship with Windows 10. For Windows the solution is to re-enable the SMB1.0/CIFS option.

How to Enable SMB 1.0/CIFS File Sharing Support on Windows 10
https://support-en.wd.com/app/answers/detail/a_id/4155