Can I replace the dead drive in My Cloud with a duplicate?

I managed to somehow kill the hard drive in My Cloud (read/write errors). I’ll fiddle with it as time allows, but in the meantime I just bought a brand new duplicate WD Red drive of the same size (6TB). Can I simply replace the dead drive with this new drive, or is there some process/procedure I have to perform before it will work?

Yes there is a procedure you have to follow. Do a search for “unbrick”. You will need to know the firmware version of your My Cloud prior to unbricking to ensure you use the right files to unbrick the new drive.

Here is one unbrick thread:

In the following link I detail the procedure I used to put a new hard drive into a v4.x My Cloud enclosure with may or may not work for others.

I truly appreciate your help, Bennor! Thank you for your guidance! I am also really nervous about following that procedure. Something bad happened when I tried to follow it with my now-dead drive. Not blaming anyone, but I can’t afford to destroy another drive.

If I connect the circuit board to the new drive, and power up the drive with it connected to my network, will it try to get update itself? What if I tried a 40-second reset?

I know you are far more experienced than I, but is there a different way to get this new drive setup for My Cloud?

BTW, I have no idea what firmware my old My Cloud drive used. If it is necessary for me to know this before I can use the new drive, is there a way I can find what firmware it used?

First generally you CANNOT physically destroy or damage a hard drive by unbricking it. Generally all one is doing during the unbricking process is partitioning, formatting and copying files to the drive. If you have physically damaged or destroyed the drive to the point it is no longer readable its due to some other cause than the actual unbricking process of partitioning, formatting and copying files.

Generally there is no way for the back-plane (circuit board) to update itself. It is the firmware on the hard drive that typically triggers the upgrade.

When you follow an unbricking process, follow it exactly to the letter. Do not skip any steps or bypass using the command line terminal if the directions call for using the command line terminal. Many here have successfully unbricked their My Clouds.

There’s a possibility that you can render the read write errors not to affect the drive [other than reducing the available size somewhat] Take a trip over to SpinWrite

Bennor - It was not the unbricking that killed my drive. It was a a power outage in my town that occurred during the process while the drive was executing a command. Better minds have tried to save the old drive, but with no success. couldn’t even dd an image file onto the drive.

I’ll try the unbricking process you indicated, but I don’t know my firmware version. Should I try the method using ubuntu and the v3.04.01-230 or try this method?

PJPfeiffer - I’ll look into SpinWrite. If it will let me make my old drive usable, that would be great. There’s no data on it that I need, so I have nothing to lose. Thanks!

I was basing my comment on your statement; “I am also really nervous about following that procedure. Something bad happened when I tried to follow it with my now-dead drive.” Which I took to mean you followed an unbricking procedure and it caused “something bad” to happen to your drive.

In any event check the P/N number on the bottom of the My Cloud enclosure. Supposedly the “- 00” number indicates the older v3.x/v4.x version My Cloud, and the “- 10” number indicates the newer v2.x My Cloud. If you have the older version My Cloud then any unbricking procedure using the v3.x or v4.x My Cloud drive image should would. Don’t know off hand if anyone’s posted a v2.x My Cloud image yet.

Thanks to you, Bennor, I have a working My Cloud! So far it is operating exactly as it should. Dashboard shows proper capacity. I don’t think I’m going to update the firmware until I read more about how it’s being received by the folks here.

I just wanted to let you know of my success and, more importantly, to say thank you. I really appreciate your invaluable help!

Glad you got it working. So far no problems with the latest v4.x firmware beyond the existing issues that has persisted through numerous firmware updates.