Can I reinstall prior, smaller RAID 1 HDDs (2) to get data?

Hi folks,
I have an EX2 which had 2 x 2TB HDDs in RAID1, and I replaced them with 2 x 6TB in RAID1. I wanted to keep the data.

  1. Turned off, replace HDD #2
  2. Turned on, rebuilt the RAID1,
    at this point everything seemed fine, I could see the data.
  3. Turn off, replace HDD #1
  4. Turn on, rebuilt the RAID1,
    however, I only had 2TB capacity, & I was too quick in rebuilding the RAID 1, & only later discovered the “Expand Capacity” option, so I lost the data.

I had backed it up to an external USB hard drive, but I had also left the back set created & the drive b plugged in, so it ran the backup, creating a 0 data backup in the external HDD, too! No more data, except what’s on the previously removed 2 x 2TB HDDs.

I tried to just turning the EX2 off, removing the 2 x 6TB’s, then inserting the previous 2 x 2TB’s.
However the drives weren’t recognizable & it wanted to format & rebuild them, which I was afraid to do for fear of losing data there, again, too.

Is there a way to rebuild the RAID 1 volume that already exists on those 2 x 2TB’s, so that I can then back data up externally, again.
Then, likewise, reinstall the 2 x 6TB’s with it’s own RAID 1 volume, and then transfer the data from the external HDD, to it?
Or, even, just rebuild the RAID 1 volume from the 2 x 2TB’s, using the “Expand Capacity” option
(will it guide me through inserting each 6TB drive in the process?).

Thanks for your help.


if you place the 2 older drives and the RAID is rebuilt, the expand capacity will let you know when to insert the new drives by the flashing red light on the unit, after drive 1 is done the light will stop flashing and then the second light will flash red, after the drives are replaced, the volume will be expanded correctly. If the previous drives are connected you should get a message that RAID roaming is enabled and should rebuild the previously done RAID.

Hope this helps

It seem I tried putting the old drives back in, but don’t recall seeing anything like the RAID roaming you mentioned (I will try it again when I get a chance). If RAID roaming doesn’t start automatically, is there should I be able to navigate to it, to force it to start?