Can I put a RAID5 array from the DL4100 into a PR4100

The raid array was configured to be roaming RAID. Will the PR4100 simply recognise it and use the RAID5 array as is?

No, it won’t.

Ooh… Right… More questions. That’s the end-of-product-life for the DL4100 where it won’t be possible to obtain a diskless DL4100? I’m thinking along the lines of what if the DL4100 I got decides to go bye-bye for good. I would have lots of data that would be inaccessible. I do have backups on other WD NASs, but it’s an interesting thing and to be honest would be a good selling point and still can be.

What of future NASs like the present PR4100 could have a migrate option built into it so if someone put a full DL4100 discs into it that the PR4100 could do a one time conversion of the DL4100 RAID to a PR4100 RAID?

Yes, it would mean once this was done then the discs could not be used on a DL4100 without a full reformat, but it does present an upgrade path to a better NAS without the hassle. Just the wait.

Thing is, for anyone who knows electronics, capacitors have a finite life time and degrade and where they catch people out is that something can be on for a long time, power something older down and you find it won’t power-up. Might do if you open the case and point a hair-drier to it to warm everything up before powering-up.

Is there an easy way to migrate data from a working DL4100 to a PR4100? Did anyone think about these issues?

Good points to send off to the teams developing firmware.

“to build into newer NASs the facility to accept disk volumes and RAID volumes from other older NAS, convert to new format and allow to be used with newer NASs. A hassle free upgrade path”. :wink:

One of my customers using a DL4100 with a RAID V had instability problems with the NAS after an Internet service outage on a Friday. We weren’t confident that we could recover and fix the problem by Monday, so we bought the last available diskless PR4100 at Fry’s and swapped the three drives into the corresponding slot on the PR4100 and when we booted the PR4100 the array was recognized, all existing folders and contents were intact. It took about 9 hours for the PR4100 to run a parity check, so we were sweating bullets. We had to recreate the user accounts. We had a problem recreating folder permissions. We would set the permissions, but they would not save. We found that if we made all the folders Public, then rebooted the NAS, we could then go in and set the proper permissions and they would be retained.

1 Like

@Bill_S, could you get someone to chase this up as it appears that migrating volumes from a DL to a PR seems possible. What do the professors higher up the WD chain say?

@MCSELEMONS, was the RAOD array initially set a a roaming RAID when the volume was set-up and formatted on the DL?


No. I’m not aware of an option for “roaming RAID”. It was set up initially as RAID 5 on the DL4100 with three WD Red Pro (3 TB) drives about a year before the problem arose that required switching to a PR4100.



The reason it worked may have been because MCSELEMONS was exchanging a set of drives that were recognizable by the PR4100, and they were doing a RAID 5, and they put the drives in the exact same drive slots on the PR4100 that it worked.

The answer is still “no it won’t.” If we can’t guarantee that it will work 100% of the time, then, for sake of the user’s data protection, we can’t say it will work at all. MCSELEMONS got lucky.


It looks like I was wrong. From what I’ve learned, with the exception of the much older drives, you should be able to swap drives from one enclosure to another. The only caveat is that you will need to do a system only restore in order to refresh the drives to the new enclosure.

What are the “much older drives”?

I know when I set-up my RAID5 array I was presented with a Roaming RAID? question to which I answered Yes. I’ll have to look-up what roaming RAID does on a WD NAS as I’ve forgotten. :frowning:

The My Book Lives and older.

Ah. I thought you meant older actual drives. You meant older NASs.

Is there a page on WD’s site that shows end-of-life and end-of-support for the various NASs. Also, thank-you for clarification that an array from al DL can be transferred to a PR.

Yeah, that’s what I was talking about.

Not that I’m aware of. Though we don’t really ever stop supporting the older products.

You’re welcome.

Nice company policy. :slight_smile:

My DL4100 has just died and it seems to be a hardware issue with the NAS as the LCD never displays anything and it just keeps restarting. There is another thread on this issue.

Anyway, ordered a PR4100 so I shall also see if it sees my DL4100 Raid 5 array…?

My PR4100 arrived.
Un-boxed it and inserted the DL4100 drives in the same slots.

Powered on, LCD works, drive lights all flashing and after a while they all went RED! (power light steady blue).

The LCD then said “Roaming RAID Array” or something similar.

With the up/down buttons I got the IP address and logged into the PR4100 web interface.

It needed the basic registrations steps and then showed the main screen indicating the data on my RAID5 setup :slight_smile: .

Another box displayed saying a foreign RAID array and to click on OK.

I did that, the four RED leds went blue and all the drives were busy doing something.

After it all calmed down I gave it the same name on the network, enabled NFS (which I use), installed Logitech Media Server (which found the existing configuration) and basically all seems well (firmware update as well).

Still probably best to start a fresh so once I am sure my secondary backups are up to date I will replace the drives with new and of course bigger ones.

1 Like

Has the “Blue light special” problem on my 2017 DL4100

Got a PR4100 and did what automan posted - same steps - same positive results ended up with a working system

My system was RAID-10 with four 4-tb WD red drives - put drives in same slots in new nas.

re-did the parameters manually after logging in via net ( DID NOT try reloading the config files)

------ notes ------

  1. Not sure the config files will work between DL4100 and a PR4100 with the same firmware or how to even read the config files ( which all all named the same what every unit you have )

  2. My backups using NAS to USB to two Mybooks 4tb via usb port were ok - so a NAS reload was an option - the backups are computer readable if you have the same problem,

  3. ( odd ,but one MyBook was exfat format and other one was old windows general format )

  4. IF you have a still working DL4100 type NAS backup SOON.

I’m facing a similar problem. We had a power outage and now the DL4100 has a blank display with a slow blinking blue power led. The drive led’s are all solid blue. RAID-5 with four 6TB drives. After 5-10 mins it powers itself off and on, repeating the cycle. I tried the 40sec reset test but that does nothing.

Was thinking of purchasing a EX4100 since it’s the cheapest available and using the four 6TB drives in it. I still have the config file backup that I plan to use from the DL4100 on the EX4100. Can I expect raid-5 to rebuild properly without losing data on the EX4100? If not, what other options do I have?

1 Like

Hi, Yorkman, this is exactly my issue as well. I just go the Ex4100 in the mail and I’m worried I’ll make a mistake installing it. Did you replace yours?

1 Like

My DL4100 dead there is NO power led . HDD led all blue. LCD shows blank. can I buy a new PR4100 directly put the HDD in?

Take my drive from DL4100 marked as 1,2,3,4. then put in my new PR4100, it recognized as Roaming RAID.
works fine. for spend $700 on a new NAS. I am not so proud. but it worked. GET all my data back
PR4100. Pleased don’t fail me this time.