Can I get files off of my dead My Book Live enclosure?

A friend brought me an enclosure asking for help. It powers up, but doesn’t connect to a network. The Ethernet activity lights blink, and the green power light in the front blinks, but none of the routers I connect it to says it’s connected.

Connecting to the computer seems to work, but due to the weird format (or encryption) I am not finding the files they want. I can browse the drive with Linux Reader, but an unable to find any real files. It seems mostly just deleted files.

The friend used Time Machine to backup files to it, and they copied several files that they would like.

Is there a way for me to get these files off? Or do I need to find another My Book Live board to try to get to these files? Or is there no other way to recover these files? I don’t know if encryption was enabled or not, my friend thinks not but I’m not seeing anything on the drive.

Well, I’ll have to recommend everybody to never buy one of these again…
Thanks!

EDIT:
Nevermind, it seems it’s not the automatic encryption one.

A My Book Live has no hardware encryption. If you are using a Linux reader to access the Linux-based EXT3 volume and find no files then those files were deleted before the enclosure failed, the volume itself is corrupted, or you are not looking in the correct location.

At any case, a Time Machine backup will be a single “.sparsebundle” file that will need to be decrypted by Time Machine. This means, finding the file, finding a way to copy that file into a Mac, and have Time Machine read it.

Ah you’re right, thanks for mentioning that, it is a My Book Live. Give me a sec and I’ll tell you what I’ve got on the drive… it seems fishy, so maybe it is dying…

Ya, so I tried to get to the SATA drive again and my computer won’t boot when it’s hooked up, so it seems the drive is dead as well. It was odd though, in Drive Management it had two 1800 GB partitions listed, a 500 MB partition, and another large partition, and the drive was only a 2 TB drive.

So if it’s the drive that’s dead, is there a chance the enclosure is still working? Or did both die at the same time?

I’m still not very interested in having the friend use an enclosure that doesn’t use NTFS…

It was interesting though, I had Wondershare data recovery scan the drive and all it came up with were images of instructions on how to set up the My Book Live.

A hard drive showing a larger-than-actual size is a clear sign of a hardware failure related to the disk drive itself.

It’s possible for the enclosure to still work. However, the WD My Book Live hosted its OS within the hard drive itself; not the enclosure. As such, in order to confirm if the enclosure works you’d need to clone a MBL virgin disk image (There are tutorials in the Community) into another hard drive so you can test the enclosure.

Most NAS devices use EXT3 or EXT4. You’ll have a hard time finding a NAS that uses NTFS unless it runs Windows Server.

At this point you may need assistance from a professional data recovery company that can dismantle and access the platters directly. Software won’t do much in case of a hardware problem.

https://support.wdc.com/warranty/datarecovery.aspx?lang=en

I do not agree when talking about older units. “My Book Live” and “My Book Studio” work the same way as “Peter Parker” and “Peter Brown” in principle. You do have a point on newer WD My Book and My Passport drives though, since there are no naming distinctions that separate them from older units.

Thanks!