Can I disable cloud access to some shares while keeping local permissions?

Hello. I’ve set up two additional shares on My Cloud Mirror. One is the default share for my user, we’ll call him bob and the share bob. Then I created another share called bob_backup and set up bob’s local account with read/write access to them. Then I mapped both separately in Windows and set up my backup program to use the backup drive. I can access both just fine.

Unfortunately when I login to the cloud I see my backup drive and data in the cloud, which I don’t want. I’m assuming it is because my email address is linked to the “bob” account and thus I have cloud access to all of bob’s shares.

I tried setting up a second user account and configure each share with different credentials but there’s two problems with that. One is that Windows doesn’t like it when two different sets of creds are used, the second is that my backup data still ends up in the cloud, it’s just linked to a different account now.

How can I remove cloud access to one of bob’s shares but still use the same bob account for data access to both shares in Windows? Can I configure granular permissions for cloud access? I’m no stranger to Linux and I don’t mind if I have to tweak some config files if necessary.


At the time of this post, remote access is tied to user accounts as opposed to individual shares.

That’s kind of what I decided after I posted and basically exhausted all the relevant Google results I could find. Also, yesterday I managed to get a user created and set up Windows drive mapping using that user account. It worked for about 2 hours then stopped working for no good reason, and won’t reconnect. I was forced to change that share to public just to get access to it again. No amount of reboots or re-setting the user password made a difference at all.

I’m happy that I got a RAID 1 backup drive and a DLNA media center working, despite the fact that none of the other features I paid for actually work. I’ve disabled cloud access and won’t turn it back on, because apparently it is just not mature enough for my needs. I’ll probably set up some local iptables rules and just prevent my NAS from accessing the Internet altogether, like I did with my previous MyPassport Wireless. That way the need to use public shares won’t bother me as much.

Overall, I’m disappointed with the My Cloud MIrror Wireless as a $370 purchase, considering that I must preclude myself from even using the cool new advanced features just to maintain a basic level of security and reliability. Hopefully a very very major firmware update is coming soon… ?