Can find in search but not library

Some of my movies can be found by searching, but do not display in library. Also, it plays just fine…I’ve restarted it every way possible with no luck, please help!

Not sure what you mean by “do not display in library?”

Sorry, shouldve been more specific. Im talking about my video folder im the internal hd, around 50 movies or so dont show up with the other 250, but can be found by using search. Thanks for taking the time to respond btw

Change the FILTER (Green Button) to ALL and see if it shows then.

Good idea, but no luck…

Have you tried rescanning you folder.

Go to the folder level where your movies are, press the Options button then select Rescan.

The interesting thing here is that if SEARCH works, it MUST be in the Media Library, because Search will only return results that are indexed.

So they’re there SOMEWHERE.  

It’ll be interesting ot see how this one turns out.  :)

Thanks for the suggestions guys, I’ve tried them and still no luck…i rescanned about 10 times. I also dont see a kutos button anywhere on your posts, im workin off an ipod which maybe the reason

Last resort:

 Back it up, all of it that you can, and format the drive. Put it all back and see if it happens again.