Can do everything BUT map drive on Win 10

OK. I’ve been looking on this site for days and tried pretty much everything here, but most of it is at least 5 years old so I’m asking now. This is on my home network. As far as I can tell, based on the info, the networks are all set with sharing on and I’ve even forced turning on the NetBIOS setting.

A) I can log into the UI and have full access to make all the admin changes I want.
B) I can log into the device through and see everything remotely.
C) I see the device in my file manager under storage, but when I click Open, it just opens the UI in the web browser.
D) When I try to map a drive letter, I type either the \\DeviceName\Public or \\IP\Public it asks me to log in. I type in the credentials for the admin and the secondary user I set up on the device, in addition as my network router admin. Get message: Do not have access. Contact Administrator.

just currently upgraded my computers to w10 and now having the same issues as you are. Don’t see any response to your problem. Did you ever get one?


Do you have, or have you had in the past, a private share on that same device? Windows allows only one set of credentials (including null credentials for a public share) between a Windows user and a NAS device. That might be getting in your way. Windows considers the device name and IP address to be different targets so if both result in the same error, this is probably not the problem.

You could try doing the mapping from a Windows command prompt and see what error message you get. Issue the command

net use Z: \nas-name\Public /user:X Y

(The command’s syntax requires the userid and password, but they are ignored for public shares.)