Can browse MyBookLive w/Finder, but not Time Machine & no front LED light at all

I’ve been using a 2TB My Book Live connected to my wireless router with an ethernet cable for a MacBook & MacBook Pro.  Everything was working fine as a network drive plus Time Machine.  A few months ago I started getting intermittent Time Machine cannot find drive errors & the alias on my desktop could not resolve, however I was able to browse the drive in Finder.

Even after I browse the MBL files in Finder, Time Machine still won’t connect.

On trying to troubleshoot the MacBook Pro, the WD software disappeared from the top right of the menu bar.  So I browsed to the software on the drive via Finder & tried to reinstall the software with the “My Book Live Setup”.  I clicked “Start Discovery” & it tells me to connect the drive to the router (except I’m browsing to it & running setup via Finder, so I know that it is connected to the router & accessible).

So then I click on “Find Drive”, it then tells me to:

Check your cable connections. -> (done)

Be sure that your dirve displays a solid green light. -> (the front LED is not on, no light on the front at all of any color, but I’m browsing files on it & the back link LED is yellow & the activity LED is flashing green)

Check your network to be sure it is working properly. -> (it seems to be since I can browse files on it wirelessly)

I then click on the “Install”, check “I accept”, and “Start Install” to try to install the WD Quick View software to help me access the MBL, I then says “No Installation Required.  WD Quick View is already installed on your drive.  No installation required.”  Except that the Quick View icon isn’t in the right of the Menu Bar, Spotlight cannot find “Quick View”, & I can’t find it in Applications or Utilities.

I am able to access the MBL via http://mybooklive locally & the bottom of that says that the status is “Good”.  I have updated the firmware on it to “MyBookLive 02.11.09-053 : Core F/W”

I have tried the Answer ID 5679 on MBL not recognized by the OS (again, Finder finds it, Time Machine does not)

I have run the full diagnostics 

I am running Mac OS X 10.6.8.

Help on this will be greatly appreciated.  Bottom line I’d like to:

  1. Get Time Machine working again.

  2. Get the WD Quick View software back on my machine

  3. Know if the LED not lighting on the front is indicative of a bigger problem or is it just not working.

Hello, have you tried pressing the reset button on the back of the my book for 4 seconds. 

Yes, I did the reset.  I can still browse the files/folders on the MBL, but Time Machine cannot find the disk (not that it was connecting before).  Still no LED in front & LEDs on back are the same (yellow link & blinking green activity).

Tried to install the software again, but same resuld of already installed & cannot discover the MBL.  Tried to turn off Time Machine & turn back on, only now now no options on the “Select Backup Disk” option in Time Machine Preferences.