Can anyone get phpBB to work on the device

I have managed to install the phpBB software and have it working fine on the internal network but whenever I try to connect from the Internet I just get the error FORBIDDEN you dont have permission to access this server. I have tried everything - putting it in the DMZ, trying different ports etc. I do not think it is a port forwarding issue as I can get an internal web server to connect no problems.

Any advice appreciated?

Welcome to the Community.

A board search for the key term “phpBB” displayed the following results:

Hopefully those threads will be able to point you in the right direction.

I appreciate the link and I have read all of these which have not really provided any information. I am somewhat surprised at the lack of help here. WD says they can not provide support as support must be provided by the App provider and when I go on the phpBB support forum I get virtually no help as everyone on there has come back with negative and unhelpful comments along the lines of that phpBB should not be installed on a NAS device and their forum is not the right place redirecting me back to WD.

WD advertises that phpBB comes with the device but yet obviously does not work or has not been tested.

OK - I have worked it out and there appears to be a serious flaw here. I need WD to address this. I can now access by phpBB board no problem once I allow remote admin Dashboard Cloud Access. The phpBB can then be accessed by adding /phpBB to the internet path.

But this is rediculous - is it the case that phpBB can only be accessed as a sub directory of the Dashboard Cloud Access and you have to allow remote access to your admin page before you can turn on phpBB to the outside world. I might be wrong here but unless someone can tell me a workaround this is just absolutely stupid! There surely must be a way to configure this differently but the Dashboard gives you no backend access to the underlying operating system!



Agreed, the implementation here leaves a lot to be desired.

I’ve just installed phpbb and it’s telling me I now need to delete the install directy. How on earth do I manage that, given that the board doesn’t have a share and I have no way as far as I can work out to get at the underlying file structure required to actually do anything with phpbb like upgrade it or install mods.

you can enable SSH access and delete the install directory via the command line, looks like it runs a linux implementation called busybox. After I enabled ssh I was able to connect to it using winscp and found that a lot easier to traverse directories etc and even successfully upgraded the version of PHPBB it was running but still unable to get access working correctly from outside my local area network.

This access is managed in /usr/local/apache2/conf/httpd.conf
Extend it by adding your rules to /usr/local/apache2/conf/extra
Do this at your own risk!