Can anyone explain this discrepancy

I ran properties on a directory on my MyCloud and got this weird result. See highlighted part.

Since that average size on disk of those ~24k files is 1MB, it’s not the problem of sector size and small files.

But there is a known issue with Windows mis-reporting SMB disk file sizes, IIRC.“size+on+disk”+error

There was a similar thread recently where this question was raised which may be of interest.

Thanks for the feedback. I’m going to copy this directory to a hard drive on my PC and see what I get.

Here’s what I get on the hard drive.


If you want to know how much space is really being taken on the MyCloud, login via SSH, navigate to the folder/directory in question, and run a Linux disk space command. e.g. du -s

I’ll need a little help. Haven’t used Linux much in last 10 years.

How to enter directory name if it has spaces? Tried ’ and ".

cd "/foo bar";


cd /foo\ bar;

You could also use [TAB] for auto completion.

oops. Things would go better if I typed the directory name correctly. :smile:

WDMyCloud:/shares/George/All EPUBS# du -s
4761476 .
WDMyCloud:/shares/George/All EPUBS# du -b -s
4815036330 .