Can access dashboard but not files

I’ve been unable to access files on MyCloudMirror since updating to Windows 10 a year or two ago. I can see the device icon in ThisPC, however double-clicking on it will only open the dashboard log in in a browser and not open the file list anymore. From the dashboard I can see that drive is healthy however, I can’t find a way to access my files from the dashboard? Is there one? I tried mapping the drive and all I get is an error message that the device won’t accept the connection. Could anyone please help me access my files? Thank you!

I have the same problem - it appears to have happened (for me) after a firmware update on 13 June 2020. Before this update I could do everything (and had done only a week before). Now I can open dashboard and Twonkey but I cannot access my files through My Cloud!

1 Like

I have the same problem.

I am havng the same problem as Shell.

It give me a login page but no way to actually log in.

Any solution?

Since last year, when Windows 10 released version 1909, and now again in June 2020 when Windows updated to version 2004, the following change to the registry is needed, if you are using Public MyCloud sharing and want to access MyCloud through windows network or mapped drives:

This solution worked for me for this problem.

Everything was working fine in Windows 10 version 1909, but after upgrading to 2004, I was getting message about group policy preventing guest access.

In version 1909, the solution that was needed was to enable guest access in Group policies settings window.

Through RegEdit:

DrNicos, Thank you for posting. I’m following your instructions, and I’ve drilled down to the Parameters folder you’ve specified, however I don’t know what to do next. I don’t have any entry called AllowInsecureGuestAuth or anything similar. Could you tell me how to proceed from here in Registry Editor? Or perhaps this parameter can be added through Command Prompt?

Within parameters, you right click, select “New”, “DWORD”, call it “AllowInsecureGuestAuth”
And set its value = 1

Thank you, DrNicos! I read in Microsoft Documents that this setting will leave me open to malware and attacks. Does it make sense to turn this setting off and on as needed? To turn it off, would I just set the parameter to value = 0? Thank you for your help!

Hi Melody, I believe this is safe. And yes, you can turn off by putting =0

Doesn’t always work. It doesn’t work here, for instance.