Cable Select overrides jumpers?

Does the use of a Cable Select cable override the jumper settings on two internal HDs? I have a WD600EB and a Maxtor 51024U2 inside my G4 Mac. The instruction sheet that came with my WD drive said that it needed to be used with the included ribbon cable, which would allow Cable Select settings for two HDs. Now, I would like the middle (WD) HD to boot as the Master drive, so I have rearranged jumpers on both drives so that the (middle) WD drive would be Master and the Maxtor the Slave. (Sorry, rest of California, for the terminology.) However, regardless of the jumper settings, the HD at the end (the Maxtor) boots as the Master. (BTW, I also tried Slave jumper settings for the Maxtor that came from its Web site in 2006, but neither combination worked.) Does anyone have advice to make the WD boot as Master and the Maxtor as Slave, other than pulling them and swapping their positions? Thank you in advance.

AIUI, to configure the Maxtor as a slave, all jumpers should be out. See page 2-5 of the following document for the Maxtor jumper settings.

DiamondMax Plus 40, 54098U8, 53073U6, 52049U4, 51536U3, 51024U2:

The following document has the jumper settings for WD EIDE drives:

Jumper Settings Info Sheet:

BTW, Master/Slave jumpering takes precedence over Cable Select. According to the preceding document …

“Even when the system, devices, and cable support CSEL, using jumpers on the hard drive(s) for Master/Slave protocol still works.”

Thanks for the link to the downloadable manual. The page I had saved from the past is still available at

They agree that J50 should be unjumpered to be a Slave, which is how I first tried it. Then I tried the settings advised for a 9-pin WD: (which also leaves J50 unjumpered). Both ways, the PowerMac booted into the Maxtor at the end of the cable, even though Startup Disk has been set to start up with the WD (in the middle) in recent years. I do not know what could make Startup Disk reset, but maybe that is the only reason it rebooted to the Maxtor. Now that I inspect System Profile, it says that the WD is Unit Number 0 on that bus, and the Maxtor is Unit 1. Does that mean the WD is recognized as the Master or just that it is the first one encountered along the cable? I will know for sure when I reboot into Target Disk Mode, which is how I knew the Maxtor was the Master before I have changed the jumpers.

It does turn out that the jumper settings in the documents you recommended were correct to assign Master and Slave. Upon booting the PowerMac into Target Disk Mode, the WD drive did come up as Master. I still do not know why rebooting the PowerMac itself brought it up by the Maxtor after Startup Disk has been set for the WD for years. Anyway, it is working now. Thanks.