BUG: MyBook Live overidden static DNS entries. (MyBookLive 02.02.02-020 : Core F/W)

Simple. I have set a static IP address to my MyBook Live and the DNS as being the router as it also acts as a DNS proxy.

I’ve now had a look at the network settings and the MyBook Live has changed these to the public DNS server IP addresses that the router knows.

Why did the MyBook Live change it’s static DNS entries WITHOUT my permission and desire?

(I’ve removed the third DNS entry. Let’s see if it reappears.)

Has not happened to me (yet), but I’ve only toyed with the Google DNS so far.

Confirmed bug

I purposfully removed the third DNS entry yesterday from the static DNS entries.  The third DNS server had put itself back in the MyBook Live’s list of DNS servers (as it is defined in the router) all on it’s own without my express permission.

Mine is doing it, too, but on the 2nd address;  I only define one.

… how do you suppose it’s learning that address if the router isn’t doing DHCP for the MBL?

Maybe this is related to UPnP somehow?

UPnP is absolutly turned off on my router.