BUG: Media library loses first half of my movie collection

I find that if I delete a movie from the hub, the media library seem to lose the first half of my collection of movies - my library only contains the latter half of my movies. I have to manually clear the media library to force it to “re-find” the missing movies. This happens about 70% of the time (the media library is correct 30% of the time).

This has happened with the last three firmware release. I’ve waited for it to get fixed but, as it’s still there with the latest release, I decided to report it.

Please fix this asap.

I don’t have this problem, do you still have it with 4+ earlier revisions?

I’ve been having this problem. When I add a movie,20 or more movies go missing. Yet if I delete one,they all come back!!

I’ve only had my hub for the last three revisions of the firmware, so I can’t comment on previous releases.

As mentioned above, I also find that adding a movie can cause the problem to present itself. It happened again this morning. This time, I removed the movie remotely (from my iMac, over the network) and when I turned my hub on, I could only see movies from “L” onwards. Very annoying.

Hello, It’s a bug for a média library:

I had the same problem as you, I disable the media library, I erased, then I rename all my files movie, I reactivated my library, everything working again properly.

Hi Karldelano.

You formatted the internal HD and had to rename every single movie file?

I’ve previously tried disabling the media library and then re-enabling it, but that didn’t work.

Hi MilkyJoe No I did not format the HDD, 1: I just disable the media library, 2: rename all files movies, 3: then I erase the media library with the hub wd live 4: and reactivate the media library, It goes back a new library :wink:

Thanks for the clarification.

Renaming all of my movies (and associated files) will be a big task! They’re perfectly named as it is. I guess I could pre-fix them all with underscores, re-enable the library, disable the library, remove the underscores and then re-enable the library again (if you see what I mean). That way I can do a simple batch rename, and I’m left with the file names I’m happy with.


Well, I’ve done that (batch renamed etc) and completely rebuilt the media library. The hub is now reporting that all of my files are new, so fingers crossed.

There’s still a bug in the firmware though, as I shouldn’t have to take such drastic actions.


It hasn’t worked for me :frowning:

I just got the info for one of my movies, and the hub (once again) lost track of the first half of my collection [sigh]

MilkyJoe:  Just want to confirm some things:

1-   These movies are all on the Hub’s INTERNAL DRIVE?

2-   With NO FURTHER CHANGES being made, SETUP / SYSTEM … / DEVICE RESTART does NOT correct it?


Is the answer to ALL three questions YES?

And, by no further changes, I mean that you’re not still changing things when you do those steps like adding or deleting ADDITIONAL files, or moving things around, etc.

  1. Yes - internal drive.

2/3. Restarting the device *usually* fixes it. Rebuilding the library always fixes it. However, the problems always returns.

No other changes are taking place when the problems occurs - I am usually simply deleting a single file or, in the most recent instance, getting the info for a file.


Try this:

   Before you make any changes, go turn media library OFF in the setup menu.

   Then make your changes and turn it back on.   

Turning it OFF is NOT the same thing as clearing it…  It just “suspends” it.

If you continue to have issues, then given how rare your problem is  (yeah, there’s occasional “hits,” but not so many REPEAT issues as yours…)

I’m wondering if the filesystem on your internal HD *is* corrupt.   Maybe you should back up your files, and use the Hub’s UI to reformat the drive.

Turn OFF the Media Library before you start putting the data back on there…

Only turn it back on when you’re complete.