Bricked WD2500BEVS after restoring foreign UNDO.BIN via HDDHACKR? MHDD cant read it

Hello Every1,

let me start with the statement im a HDD n00b, living in Poland.

Here’s my story:
few years back I bought brand new WD2500BEVS-22UST0 which was already hacked to work with Xbox360. It was recognized as 120GB drive, working perfectly well for over 2 years. Since I’m not using my old console any longer, I decided to used the drive as a network device by putting it into some hdplayer, formatted it and forgot about whole case.

Recently I figured out why not to use whole capacity (250GB) instead of current 120GB. Till that time drive was working perfectly fine but what interested me the most, is that Bios recognized it as FUJITSU :)

Anyways, straight to the point. I have downloaded HDDHACKR, created bootable USB stick, used Restore Firmware option and uploaded UNDO.BIN file onto my drive. Let me mention that I never had original UNDO.BIN for my hdd hence, I have used the one supplied with HDDHACKR package (ver. 1.4).

Since that horrible mistake, I started having huge issues with the drive:

  • my bios (old HP dx2300) sometimes recognize my HDD but does not display SMART status or I can’t run self-test on it (nothing happens),
  • my win7 cannot detect the drive,
  • tried accessing MHDD via bootable USB - no luck, it does not recognize my drive,
  • tried re-loading UNDO.BIN via HDDHACKR - sometimes it works, sometimes not,
  • tried running Disk Health from bootable Parted Magic CD - it does not recognize my drive

What I have noticed is that if MHDD/HDDHACKR can see my drive, I can switch if off while running and re-connect power cable and only after that, both apps are capable to recognize it but further analysis is not possible.

I even tried connecting the drive to other PC, this time Bios can see it properly, even the LBA size is displayed properly but when I try running DPS Self Test (HP desktop), drive clicks few times, stops spinning and PC freezes.

As mentioned, I’m sure that till the time I reverted the xbox-related changes and uploaded UNDO.BIN via hddhackr 1.4, drive was working perfectly fine, few minutes back I managed to copy it’s previous content into another drive I have and it was successfull and fast too.

Any suggestions other than “throw it into trash” would be highly appreciated. I don’t have any sensitive data there but thought that it’s worth trying to fix it by myself. Please help!!!

Best Regards,

Download WDR. There are several versions here:

Use WDR to retrieve all the firmware modules from the drive, plus the “ROM”. Then attach them to your next post.

If you can do that, then I may be able to help you.