Bricked my EX2. <Also how I unbricked it>

Thanks for your replies!
I disassembled my device. It appears mine doesn’t have a connector soldered on, like yours. I ordered this cable : http://shop.clickandbuild.com/cnb/shop/ftdichip?productID=53&op=catalogue-product_info-null&prodCategoryID=105
It seems to match the specs to me.
I will solder cables to the board and hope I can get it to work.

Have a nice day

Thank you so much. Your article helped me fix the broken NAS :smiley:

It’s an old post but i will try the experiment as i have nothing to lose and now try to fix things instead of throwing them…

so here is the noob question :
Can i use the following product for the missing 5 pin connector ? if not can someone redirect me to the electronic part i should solder?

Hi!

I’ve tried to boot after into Linux afterI loaded the uImage und uRamdisk, but I always get the Error
“Verifying Checksum … Bad Data CRC
Ramdisk image is corrupt or invalid”
How should I proceed?
I have no clue what to do, I already tried different uImage and uRamdisk files from the EX2 Ultra GPL Source Codes Downloads.

Thanks for any advice!
Sincerely
EX2Ultra

Thank you very much! This tutorial helped me to bring my broken NAS back to life!
Lessons learned:

  • On Ubuntu 20.04, minicom did not respond to keyboard input. Using putty instead, it worked right away!
  • bootcmd on the Marvel boot prompt uses single quotes instead of backticks! this needs to be replaced during copy&paste

hi again,
i manage to get ip adres, but i cant connect do disk anyway, at least i can connect from disk to computer via lan. thats plus now i have face it another chalenge.

i have no “local” in /usr/ that means i have no updateFirmwareFromFile.sh
and i also couldnt use dhcp command, instead i had “udhcpc”

Good afternoon everyone. I own a WD EX2 Ultra out of warranty.

WD support has not given me more support than the 4 and 40 second reset.

The problem is that when canceling the AutoBoot, with the prompt in Marvell>> I have not been able to carry out the correct command to reset the firmware.

It always starts in Safe Mode and does not recognize the power to load new firmware.

On the other hand, when booting completely, the user is not root but another one with which I cannot enter with root/mycloud.

Attached evidence…

Please press Enter to activate this console. LED_POWER_ON
sh: sata_disk: not found
sh: /usr/sbin/alphaAlert.sh: not found
sh: /usr/local/sbin/sendEmailAlerts.sh: not found
sh: /usr/local/sbin/ackAlert.sh: not found
Can not read /etc/nas/strings/es_ES/alertmessages.txt
sh: send_sms: not found
sh: ganalytics: not found
Can not read /etc/nas/strings/en_US/alertmessages.txt
sh: snmp_tool: not found
traceroute: bad address ‘www.wd2go.com
traceroute: bad address ‘www.wdc.com

starting pid 2180, tty ‘/dev/ttyS0’: ‘/bin/login’
Password of alerdoci:

I know for the original user who was bricked upgrading from OS3 to OS5.

He hasn’t answered me with the password yet.

Any help to do a forced reset that 40 seconds does nothing?

Thank you very much for the support.

Let me share my experience…
First of all THANK YOU SO MUCH TCWORLD for the knowledge shared!!!

Bought one from ebay, came bricked with solid red light.
After soldering the J2 pins and reading the serial output it wasnt able to trigger the ip configuration.
Following TCWORLD steps and going to the Marvell bootloader I noted a command (if you write ‘?’ they are listed):
Marvell>> resetenv
which erased something and after
Marvell>> reset
the unit went into Safe Mode where there was IP assign finally and also managed to open the IP with the browser, showing Safe Mode page with a “Firmware” version “2.0.0.x” and also u are able to upload firmware from it.
After some try and error dowloading all 2.x firmware versions, flashing them hoping to match the previous version there was no success and it didnt initialize the network interface. So “resetenv” → “reset” → flash from the page… and again and again with all 2.x version nothing worked so far.
After some reading around the forums someone said that this “Firmware version 2.0.0.x” points to OS5 firmwares so i downloaded firmware version 5.x… and after safe mode flash it finally worked.
After the web UI setup it found newer firmware and i let it install it so for the last 12 hours it works fine…