Bricked by latest update?

I just got high speed internet back and decided to update my SMP, after downloading and installing it just hangs on the splash screen. I’ve tried putting the update files on a usb drive, pressing the reset button on the bottom of the unit, which did nothing. I tried hooking it up via composite and by HDMI and still it just hangs on the splash screen with the clouds and the logo.

Has anyone else had this problem? I feel like the solution is right around the corner, but I’ve made absolutely no progress.


For how long are you pressing the reset button?

Did you have any power outage while updating.

I tried pressing the reset button for just a second or two after it boots and before powering on, neither way showed any result. I also tried to press it for 10 seconds to change the video mode but that didn’t seem to do anything either whether it was hooked up by HDMI or component cable.

There was no power outage, I set it to update and it did everything up to the reboot, after the reboot it just hung on the splash screen. I didn’t want to mess anything up so I left it on and went to bed, it had been on the splash screen for half an hour already. When I checked it in the morning it was still hung on the splash screen. That’s when I started experimenting trying to get it do anything.

If you came to this post looking for a solution to the same problem I had, I’m sorry to say there doesn’t seem to be one. I’m retiring my WD TV SMP to a drawer with a slightly sour taste in my mouth from the experience. I’m not big on just throwing away things when they’re broken, I’d much rather fix them, but to be honest even when it was working just as advertised, it is still a hassle to deal with.

Have you tried using both USB ports.

Have you tried using a different USB flash drive.

Did you make sure that only firmware files were in the root of the USB drive.

Did you disconnect other drives etc from the player except for TV lead.

Is there any flashing of the USB drive led / player led.

Have you tried using rollback firmware with the modified ver file.