Brand new laptop with Windows 10 not seeing WD MyCloud EX4

So I got a new laptop with Windows 10 Pro with v1803/OS Build 17134.228, and I’m not able to access the shared on a WD MyCloud EX4. I was able to see them ok with my old Windows 7 laptop, however not able to now. My wife has a Windows 10 laptop and she is able to navigate to her shares. So I don’t understand what is going on.

Here is what I’ve done to try and fix it:

I’ve enabled SMB 1.0 using the following URL: https://support.wdc.com/knowledgebase/answer.aspx?ID=20736

I’ve downloaded an App from the Microsoft store called WD. Seems to install ok. When I try to run it, I get N supported WD devices found.

I’ve tried to install WD Access Setup. Again, it seems to install ok. However I don’t get an icon in the Windows Tool Tray and I don’t know of any other way to start this.

The WD4 shows up under devices, however if clicking on it. Nothing happens.

I’ve tried to map to the drive using a private Class C address and the directory I have access to and still nothing.

I’ve rebooted the WD4 and still not able to access.

Any advise?

thanks

Answered my own question.

I disabled TCP/IP NetBIOS Helper along with SMB 1.0, which both are insecure. Yet WD ships a product that needs these enabled…