Brand new 8TB Easystore can't access, can't initialize

Just got this brand new 8TB external Easystore drive. When I plug it in Windows 10 installs the following driver: WD easystore 25FB USB Device
And that’s it, nothing else happened. I went to the website, downloaded WD Discovery and WD Drive Utilities.
WD Discovery says it’s in read only mode and needs to be formatted.
WD Drive utilities: Run drive status check: SMART status failed.
Finally I went to Windows 10 Disk managment.
The drive shows up as uninitalized. I right click and hit “initialize” and select MBR or GPT, it doesn’t matter which because they both give the following error:
“Virtual Disk Manager: The Device is not ready”
I’ve tried moving the power cable to another outlet, and tried switching the usb to another usb plug.
Also tried connecting it to another PC running Windows 7. Same error “The device is not ready”.
Any ideas before I give up and take this thing back?

Try downloading WD Security and WD BAckup. I think you need them to get started.

WD Security: All it says is “Attach a supported WD drive”

WD backup: When I go to backup the easystore drive does show up on the list, however when I select it and hit “next” it says: “No writable partition found. Please make sure your drive is unlocked.”

I guess you are right. Try using Support. You may be able to get help there, or return it.