Brand new 3Tb My Book not showing up

Well here we go…

I just bought a 3Tb My Book Essential external drive this afternoon. I’m running Win 7 on an Acer Aspire laptop - 2.4Ghz processor and 6 Gb ram…This evening  I took the drive out of the box and read the only documentation \ instructions that came with it, which was essentially 3 steps: Plug the ac adapter in, connect it to the drive, and then plug the usb into the computer. When I plugged the power into the drive the white light came on - on the front - so it has power. When I plugged the usb into the computer the new hardwre icon came on in the taskbar telling me it was installing. It did it’s thing and then told me it was succesfully installed. I waited and the icon then faded out. I opened up explorer, went to my computer and the drive wasn’t there. I checked for the saely remove hardware icon and it wasn’t showing up because it apparently isn’t detecting any hardware that it can safely remove. So I rebooted with the drive plugged in and it made no difference. Rebooted with out, then plugged it in, and no difference. If I go to Device Mgr, under Disk drives it shows WDC WD6400BPVT - 22HXZT1 so I know it’s there. I have a second WD 1Tb drive that has worked great from day one - effortless install, reliable and no prob, but I’m now needing something bigger. So I thought this 3Tb My Book would be a good choice. Apparently not so from what I’m reading. I’ve tried unplugging the power, plugging it into differnt power outlets, and plugging it into 3 different usb ports, but I didn’t expect any results from that because it is showing up in Device Mgr.

Why oh why oh why WD, did you get away from making a solid, simple, effective external drive, and enter the market of providing goofy backup software?? The 1 Tb WD drive purchased two years ago - a WD Elements Desktop - is a different animal. It’s meatier … the case is way tougher …  it’s wieghtier - a good thing  … it sits horizontally - the way it should for a device that we all know is sensitive to drops or falls even if it tips over accidentally as it could with the current design.  Why stand a drive vertically without a solid wider base, or enough weight to justify that positioning? My other WD  1Tb drive is basically an extension of the Win OS without having to navigate or bypass or try to sync yet another program to Windows. I mean what user can’t cut \ copy \ paste \ drag and drop. What really irks me is that when I purchased this today I asked the store clerk three questions: Is it compatible with Win 7? Yes. Is it plug and play? Yes. And finally - important  - does it have any of that goofy backup software that comes with so many drives these days? Oh no, he laughs, no  … ahem … cough

I consider myself lucky. Unlike others on here who have posted about this problem, I found this out from day one and I have no lost data. I can return this to the store tomorrow cause there is no way I will trust my data to this drive. If I have somehow royally screwed up the install, then I consider that WD’s problem for not providing any other documentation with the drive out of the box, other than the 3 step graphic. The solid white glowing power light on my drive is on and there is an obvious power button on the back which I also tried, which did nothing. Wading into posts on this forum, I’m reading somehitng about the power button only working with certain software and something about it glowing green? Why should a user be left to guess as to why a provided feature - a power button - requires some app to enable \ disable it? If I’m troubleshooting a problem with a product that just came out of the box, some basic info would be helpful.

Too frustrating. I will see how it goes at the store tomorrow. My hope is to be able to exchange this. I just hope it isn’t one of those situations where they say it is now between me and WD to fix.

Hi, the backup software shouldn’t have anything to do with the my book being recognized. For troubleshooting connect the my book power cable directly to a wall socket and check if it is recognized on the disk management window. Follow the link below for the steps to get there.

I just finished writing a lengthy response \ explanation which dissappeared into cyberspace. The gist was …

I had initially posted that my drive showed up in Device Mgr but not in My Computer. The item I listed in my post was actually my laptop’s internal HDD. I confirmed this by checking the BIOS.

WD’s solution is first to try replacing the USB, then

“If the drive doesn’t show up in either Windows Explorer or Disk Management,
then the drive should be replaced.”

 I didn’t want to spend anymore time trying to resolve this, so the easy solution was to return the drive this morning. The store happily gave me a refund and I bought a 3Tb Seagate. Out of the box to usig it was 5 minutes. As I write I am nearly 1Tb into  data migration, wheras had I stayed with that drive I could have my thumb up my **bleep** for five to eight days over the holidays waiting for a USB cable to arrive. Feels like I dodged a bullet actually. The experience turned me off WD, even though I’ve mentioned I’m happy with my WD Essential. It’s not just that the drive failed - drives fail, it happens -  but that the drive is poorly designed, and that this is a known issue that hasn’t been resolved and WD’s proffered ‘simple’ troubleshooting was not at all simple.

Follow that whole process through including the clickable links to reformat, initialize or write a signature and  \ or Write Zero’s using the Data LifeGuard  Diagnostics software…Hardly Simple.  A simple Format in Win is:right click, select format and format. Today it’s laughable; yesterday it was loathable. Feel sorry for the folks on here who’ve lost data. I’m much happier with my new Seagate and chalking this up to bad research on my part. Moving on.