Bought refurbished live plus -> 4 things wrong in 20 minutes :(


#1

so i got home and installed the live plus HD media player. copied some files to a usb drive and it played wonderfully on tv. and then the problems started. first, if i tried to view a movie or mp3 file a second time, the media player would show the search icon for several minutes but never play. after 5 minutes, i gaved up.

i turned off the unit, plugged the usb drive into my computer and deleted the files that the media player created and the files played fine on the unit.

so i decided to update the firmware to 1.04. copied the files my usb drive, ran the updater. the media player unit installed and reboot 3 %@!^ TIMES. after the 3rd reboot i removed my usb drive, and i got the error message saying “insert usb with firmware blah blah blah” which i did and it didn’t work. 3 times. so i deleted all the media files and left only the 3 firmware files. didn’t work. tried another usb stick. didn’t work

so i tried resetting it with a paper clip. apparently the pape rclip pushed the reset button further in and didn’t do anything. so now im returning this POS and getting my money back and never buying another refurbished western digital product again.