Bought a WD40EZRZ but PC thinks its a WD15EADS


#1

Hi all,
I replaced an old Western Dig. WD20EARX (2Tb) that seems to have fried with a 4Tb WD40EZRZ. Win10 Disk Management tells me it’s a 1.5Tb disk, so converted it to GPT and got my PC booting in UEFI rather than legacy bios thinking it was a partition issue…still the same. I can create a ‘simple volume’ on this disk no problem, but still only shows capacity as 1397.25GB.

[REMOVED DUE TO PRIVACY POLICY] Note: one of the images contained the HDD serial number

Then I looked closer, and the model number shown in Disk Management is WDC WD15EADS - a completely different disk to the one in the machine! Why is my PC thinking I have this HDD installed, when clearly (on the packaging, receipt & sticker on the HDD itself) it’s not? It was bought from PC World in the UK, and fully sealed/packaged when bought, so unlikely they’ve ripped me off.

(System Information confirms I have my PC booting in UEFI mode and have converted the drives to GPT).
Thanks.


#2

Well, your PC is not making up model numbers all on its own, so it is actually the drive reporting its model as WD15EADS.

The WD15EADS is a real product… 1.5T Green SATA Drive.
The WD40EZRZ is 1 4.0T BLUE SATA Drive.

So something is wrong with the drive (UNLESS you actually have a 1.5T drive installed and you’re not poking on the drive you think you are. :slight_smile:

You might try checking the warranty status of the drive in the WD Support Portal (which will ask for its serial number) – if the serial maps to the correct product, then that’s also strange. But if it maps to the 1.5T Green, then that’s a whole new thing!

Portal:


#3

Well - this is what the Warranty Status says (thanks for the tip BTW)

A google of the Model number returned shows a 4TB Blue. I’m pretty stumped right now. I took a pic of my DiskMgr with and without it plugged in, so I’m 100% certain I don’t have another HDD hidden somewhere!


#4

Hmmm. I notice in your pics on your first post that the label looks suspiciously worn. Is it peeling up at the end like it looks like in the picture? And wrinkled?

Go ahead and initialize the drive, then get the WD DataLifeguard diagnostics software and see what it says the S/N is.

The top of the label is too blurry for me to read, but is the “Date” shown (the manufacturing date) reasonable for when you bought it?


#5

OK. So I ran that diagnostic tool…Again, it shows up as a 1.5Tb HDD. S/N WD-WMAVU0264250…

And as for the date in the previous image I posted, that shows the Status as ‘Out of Limited Warranty’ and the Date says 19th June 2018…I bought it this Saturday just gone…

The label does look a wee bit peeled on the lower edge I guess, but not suspiciously so… The glue seems pretty strong though… it doesn’t look like it’d peel off without ripping (I’m loathed to try as it’d make it more suspicious and voids the warranty!)

I’m wondering if WD actually manufacture identical units for use, then just ‘flash’ them to be different sizes… perhaps it’s cheaper for them to have just one production line making one unit - and this one got badged/flashed incorrectly? Either that, or it’s a shop return and the previous owner put their old 1.5Tb HDD in the bag?.. But it came sealed in the antistatic bag with all the documentation & silica gel packaging. They went to a lot of effort if so!


#6

Best bet at this point is to probably contact WD support and let them know what’s going on. You might have unwittingly purchased a counterfeit, or it could be a manufacturing error – might even call the shop you bought it from and see if they can manage the swap for you.


#7

Thanks for yr suggestions with this Tony… thought I’d update you… I took it back to the shop today after speaking with WD support over the past few days. They had another in the shop so I went to exchange it, and that one had a half-peeled sticker and the anti-static bag it came in had been taped together, rather than heat-sealed. Very odd. Anyway, I ducked out & took a refund. Found one online for £20 cheaper - delivered tomorrow :slight_smile: