Blue (solid) light power, both disks (solid) red light. 40 sec reset and now need to choose RAID and possibly delete everything? HELP?


I need help. I could never get it stay connected and would need to unplug/plug almost every day if I needed to use the files on it. Possibly because I didn’t have the static IP set up. However now since yesterday the power stays on blue but the drive LEDs are red (continuous…not flashing). I can’t connect. That’s pretty bad I have important images there, I am a wedding photographer. I also have bunch of personal memories there.

I tried to restart, used the reset button. Still red.

Now I tried the 40 sec reset which should still keep my data save. BUT now it asks me to choose RAID (spanning, RAID 0, etc) but also tells me choosing anything will delete data on disks? I can not let that happen. So now I am stuck, what do I do with this piece of …?

Have you opened a support case? For more information, please contact the WD Technical Support team for the best assistance and troubleshooting: 1

yes i did. i was told to try to connect the drives via SATA cable which i did but nothing shows up not even with the linux viewer as in this post

i dont know anymore, i asked if i need a SATA adapter with power maybe? because when i connect them nothing happens…silence. but i was told they should get power via the sata cable. :frowning: i dont understand how both drives could work one day and not the next…

For 3.5 inch hard drives that are found in the My Cloud enclosures one needs to either connect the drive to a computer’s spare SATA port, or use a powered USB to SATA adapter or powered docking station. Example of a powered USB to SATA adapter:

There are similar adapters available both in the United States and in other countries.

In certain cases one may have to mount the drive in Linux if Linux doesn’t automatically mount the drive or it’s partitions.