BLUE SN500 M.2 undetectable at cold boot

#1

I installed it in my laptop,
motherboard was z170.
It juse dosn’t showup at COLDBOOT(or called COLDSTART) ,

I have no idea how to fix it.
disable fastboot?————Tried(my bios dosn’t have any boottime setting,so disable was my only option)
Change M.2 Slot?————Tried
Single drive coldboot(no HDD or SSD else SN500 Startup)——Tried
User another drive on my motherboard——Tried,and it worked(P.S. I haven’t anothe NVME drive,so I grab a NGFF SSD tested.)

Because I don’t have another motherboard or M.2 drive,
so I can’t come to a conclusion it was a motherboard or M.2 drive problem.

Have you any guys facing(or faced) with same problem and can tell me what shoud I do?

I just want to know , motherborad,SN500, which calls this problem?
If it’s a drive problem,I can send it back and change a new drive.
But if was a motherborad problem,send it back just wasts my time.

Because English wasn’t my native language,so sorry with my poor English,
thank you.

#2

You should specify what laptop and series is that and what bios version you have on the laptop…

#3

Thank you,
laptop type is Clevo P751DM2-G,bios version is 1.06.05(it’s a ODM verison)
I have contacted the distributor and they say it was a BIOS problem.
Now preparing to write a latest verison bios.
Hop it works.