Blue light fixed on wd mycloud, (not quite) - need to rebuild access to files1

Having already done these commands that as it turned out was NOT a good suggestion, but, once again, having already ran them…?

dd if=/dev/zero of=/dev/sda1
dd if=/dev/zero of=/dev/sda3
dd if=/dev/zero of=/dev/sda4
dd if=/dev/zero of=/dev/sda7
mkpart ext4 /dev/sda3
mount /dev/sda3 /mnt/root
mkdir /mnt/root/boot/
cd /mnt/root/boot

Should it affect anything the outcome?

These should not be necessary.

nonono, these above commands, I already RAN sometime ago during the whole process of trying to get the blue light to turn steady. what am asking is that, since I destroyed those partitions, if this new set of commands will it write them from scratch, no matter what state they are right now

Your fine. Just run the 6 step that you posted.

PS Just for fun what country are you in?

Argentina, what about you?

US Michigan I was going to guess Spain.

Well, I can’t thank you enought for all your help. I’ll keep you posted on these final steps. I’ll most likely do it tonight when I get back home

Your welcome

In ref to mkpart commands. Are those to be fast to execute or each one take a while?

They should be fairly fast.

As you requested, I tried running run smbcmd -c after rebooting the disk, but it did NOT got the shares back.

Now I’m proceding with formatting the drive

Ok thanks. I didn’t think it would restore the shares. Since the /dev/sda3 and /dev/sda7 and /dev/sda4 were zero’d. I suspect that it keeps information about the shares so they can be recreated.

No problem.

I format the disk, applied the firmware, that went pretty inmediately every step, now, reboot is taking over 10 minutes… is that normal? how much time should it take? (meanwhile, there are no IP used and the drive is with blue blinking light)

Did you get the red/yellow led?

nop, blinking blue 20 minutes…

Then you need to boot from the USB. Then mkdir -p /mnt/usb /mnt/boot
mount /dev/sdb3 /mnt/boot
mount /dev/sdb1 /mnt/usb
cd /mnt/boot
ls -l
cd /mnt/usb
ls -l
Verify the sizes of the uImage and uRamdisk on the boot partition with the size of the /mnt/usb recovery images.
This is to verify that the correct uImage and uRamdisk is in the boot bartition.

wait hold on… i unplugged, and just for the hell of it, i decided to let it boot again without the pendrive. Blinking blue light, BUT the IP address was responding. all of the sudden, i could get back into the dashboard. No volumes though…bummer, but i think that if i create them from there it should work? am i correct?

The screen says that it is formatting volume_1. I would wait until it is done.

FINAL SUCCESS - I have my drive back (empty).

Starting to the process of copying back everything.

THANKS TO EVERYONE THAT HELP ME. ESPECIALLY TO RAC8006 TOTAL GENIUS & BADASS !!!

You should mark this as solved. Find one of your post and you should see a check button. Just click
on the check button.

1 Like