Blue LED, no connection to MyCloud

So a week or so ago i lost connection to MyCloud, it was visible in the routers list of connected devices, but i had no access to dashboard or the drive itself. I had to pull the power cable, after a very long white light it was found in the network and working as usual.

Today it lost connection again. Steady blue LED, but no connection, even though router sees it as connected to network, i can also sucessfully ping it. Of course there is no access to dashboard. I tried rebooting and even restoring it using the pin thing, no reaction at all. Pulling the cable doesn’t work either, it just goes in steady blue led, no connection state.

What should i do?

Hi there and welcome to the WD community.

Try to press the reset button for 40 seconds see if this helps the unit reboot correctly. If this does not work then i recommend contacting support for further assistance:

You can also after power cycling the unit verify if you have the latest firmware on the unit installed.

 i can also sucessfully ping it. Of course there is no access to dashboard.

I assume you use the same IP address you used to ping to try to access the dashboard?


Yes, i used the same IP.

After i unplug it, wait a minute and plug it in again, i can access the dashboard, but after about 20 minutes it is gone. It works fine at first, i can change settings and do things in the dashboard, but then some functions appear greyed out and after a minute it loses connection altogether.

I did the full restore by holding the pin for 40 seconds, and the same story happens again. No access to the dashboard, not visible under network tab in explorer, but visible in the router’s list of devices and can be pinged.

Just out of interest i pulled out the network cable out of it, after that you would expect to see a blinking led to inform you that the connection is lost. Nope, not a single reaction, still a solid blue led.

Looks like something is wrong with the firmware. I am using the latest version (probably) dated May 13th.

Ah. Dashboard did work.

Have you got a lot of media on it?

Could it be hanging up due to the thumbnailing and indexing processes?

Well, it could, i have plenty of photos, well over 30.000, but why would it create thumbnails now, i uploaded all of my photos to MyCloud the day i got it, which is about a year ago, it should have created all the thumbnails then and it worked just fine.

Anyway, i don’t see any hidden .wdmc directories, only some temporary folders that are empty.

Do you think deleting most of the photos might help? Just to see if it works, it is not my primary backup anyway.

has this only been since the FW update? I have not confirmed but it appears some FW upgrades re-generate thumbnails.

If this start after the upgrade I would let it run a few days and see. if still bad do a system only restore.