Blu Ray ISO issue on WD TV Live SMP

I’m new to the whole movie ripping world, but I’m having issues with playing Blu Ray ISOs on the WD TV Live SMP.

First, it plays DVD ISOs fine, no issues, but it stutters on the BD rips. I’m playing it from a 3TB Seagate drive connected directly to the USB port.

I’ve tried playing ISOs using Blu Ray copy in DVDFab - Stutters
Playing ISO ripped using Blu Ray Ripper in DVDFab - Stutters
Also, I ripped a Blu Ray using MakeMKV and it still stutters.

It will play a couple of seconds of of the movie and audio then pause a second, play a few more seconds, the pause a second, etc…

I’m using the latest Firmware 1.05.18

Any ideas? I’m I doing something wrong?


Mate, having the same problem as you and its doing my head in! have bhought atleast 3 different routers…

Some virgin rip bluray titles will not play through the WDTV Live boxes. Maybe if you posted the title of the movie the issue can be resolved.

Have you tried a complete power cycle of the device (hold down power for 5 seconds)? Then watch the Blu-ray and see if it stutters. There is a bug with cache management, and power cycling the device is a temporary workaround.