Blinking Blue Power LED - MyCloud not working


#1

Dear community,
I have a 6TB My Cloud device which has had a blue power LED blinking for the last two months, after some power cuts at home (I live in Argentina and power cuts are quite normal).
I’ve tried different things with it and haven’t been able to solve my problem. First, I simply waited (for more than 2 weeks) for the file system check to complete. It didn’t. Then I tried disconnecting it and then waiting again for at least seven days (a couple of times), it didn’t work either.
Then I tried a 4 Second Reset and also a 40 Second Reset. Neither worked.
At this point, I lost of hope of regaining use of the product, and sadly the warranty period has passed. I just wanted to know if there’s a way of recovering the data inside the device. I tried connecting it via USB and Ethernet to my Windows PC, but the device doesn’t appear.
I really need to recover the information in my device. I have over 2 TB of memories in there.
Can you please help me?
Thanks so much in advance!

Damián from Argentina


#2

You can remove the hard drive from the My Cloud enclosure and attach it to a PC that has the proper 3d party Linux drivers installed to read the contents of the drive. Or use a Linux PC to read the contents of the hard drive.

If you have a a second gen v2.x single bay My Cloud it appears quite a few others have found their device bricked with a flashing front blue LED. Use the forum search feature, magnifying glass icon upper right, and search for those past discussions which may hold additional information on that particular issue.

One can “unbrick” their My Cloud drive so long as the hard drive isn’t damaged by using one of the various unbrick methods. Again, those past discussions can be found by searching the forum for “unbrick”.


#3

You’re a so kind, Bennor. I will search for “unbrick” and/or try reading the contents of the hard drive on a Linux PC.
Best,

Damián