BIOS won't recognise two Elements SE drive simultaneously

I have two Elements SE drives, a 1TB and a 2TB. If I connect EITHER of them to the PC, the BIOS recognises it, but if I connect BOTH of them it only sees one. My guess is that each drive is identifying itself to the BIOS in such a way that the BIOS thinks they are the same drive and so only recognises the first one it discovers. Obviously I cannot change anything in the operating system(s) since the hardware cannot see both devices at the same time.

Any advice?

In some cases, storage device is not properly connected to computer and it cannot be recognized, for example, there might be something wrong with power supply, cable or USB port, etc. Hard drive capacity is unallocated. Disk is not enabled in bios or device manager.

I suggest you to try the below solutions once & share the outcome:

  1. Check the USB port
  2. Update the disk drivers
  3. Partition & Format the drive

Hope it helps!

Thanks, but as I said, I can see EITHER drive on its own, including in the OS when the PC has booted, so I don’t see how it can be a driver or formatting problem. I’ve tried using different ports and cables and so eliminated them from consideration. The problem is that the BIOS cannot see BOTH drives at the same time, which suggests there is some problem with the way it is interpreting the drives’ firmware. Has anybody else experienced this?

Seriously? You are suggesting that they erase their data?

I’d start by connecting both drives to another computer to see if the same thing happens. If so, then we need to explore the issue with the drives. If not, it is an issue with your system in particular.

My first thought is that your system’s USB controller is the issue. Correct me if I’m wrong, but the Elements SE is a portable USB drive without external power. That means that they are both drawing power from the USB bus and initial gut feeling is that your USB port is unable to power both drives at the same time. A work around for this would be to get a powered USB hub where the hub gives power to the drives and not your computer.

Any, check it out and report back.

I am able to see both drives simultaneously on another computer.

I tried using a powered hub as you suggest, but still only one drive appeared. I also tried connecting one drive at the same time as an external CD drive which uses two USB connexions because it draws more power than a single USB can supply. Both the Elements drive and the CD showed up. This suggests that the motherboard is capable of supplying enough power for two Elements drives, which only use a single USB each.

Also, the LEDs on both Elements drives were lit continuously, suggesting that they are getting power from the USB ports. The motherboard is an Asus Prime B550-Plus, which should be capable of providing enough power.

Since both drives show up on another computer, my current thinking is that the motherboard is not interpreting the ID data from the drives correctly and thinks they are the same device. I would be interested to see if anybody else has experienced this, but I think I need to pursue it with Asus.

Update:
I have now tried a Seagate USB-powered drive and I am able to see it and either of the WD drives at the same time. It seems unlikely that the WD is drawing significantly more power than the Seagate, so I think we can eliminate that as a possible cause. My conclusion is that either:
a) the WD drives don’t identify themselves to the BIOS properly
or
b) the Asus BIOS isn’t reading the WD indentifcation data correctly
or both, with the result that the BIOS thinks they are the same drive.