Beware: WD20EARS internal drives not compatible with all PC's


#1

Folks: Beware that WDC’s 2TB Caviar Green HDD may not work in your specific machine even though you’re running the Vista OS.  WDC advertises these drives will work in Vista OS machines which is the reason I purchased them ($99 per) to begin with. Upon contacting WDC customer support [name withheld], I was advised this is not the case depending on the age of the PC (mine is an HP, just a couple years old). Although the WDC HDD specs do not indicate this, and nowhere on the WDC website is this footnoted, highlighted, or even fine printed, WDC will still not allow a return and refund. So before you get stuck with a 2TB paperweight as I have (2 of them)… I recommend you look for another manufacturer who stands behinds their product specs and website content. If anyone out there knows these drives will work in their machines and is interested in 2 brand new drives at a reduced cost please reach out to me…


#2

dont hou have 15 days to return your drives to the store??


#3

Thanks… but if purchased thru CompUSA.com they do not accept returns at all for hard drives, internal or external.


#4

ok sorry

its strange that a computer doesnt accept that drive but is possible of course

did you try run the drives in sata speeds only and not sata two?


#5

Sorry to hear this… from WD perspective you can see how they can not field refunds, that is why you take it upon yourself to be the “tech” and did not buy a pre-built system. Your supposed to know about a million things! Anyway, things are really changing, I had to update my BIOS to properly using my WD20EARS as well, in fact I had to get a custom bios because Asus quit supporting my board.


#6

Hmmm I wasnt aware you could run the drives in different speeds. The underlying problem is the drive wont format, quick or full format – it stops at 54%. Tried both drives and they both stop at 54% format, so in essence it stops at 1TB’s worth. Interesting though is the BIOS setup recognizes the drive at 2TB. I’ve been able to successfully format the drive manually forcing it to 1TB, and the rest just goes to unallocated. 1TB isnt terrible, but not what I paid for – or wanted cause I was planning on using these drives for network backup and mirror for all PC’s in the house. 


#7

What prompted you to update your BIOS?  Were you having trouble formatting the drive or did the PC just not recognize it?


#8

Sounds like you have an HP issue as well as a Microsoft Issue.

  1. Bios recognised 2tb drive. So your motherboard finds the drives. HP model -? and usually the board manufacture has specific info for drive support. Contact HP

  2. Vista only formats to 1tb. - contact Microsoft

You might purchase a SATA controller card that can set up the Raid or you could try partitioning 2 1tb partitions - since you say the system will format at least 1tb.


#9

Thanks for the advice. HP indicates no issue with a 2TB drive – they don’t suggest greater than 2TB and have had numerous complaints about Western Digital drives – shocker.  Microsoft…? well ever try getting an accurate response from those guys? They always blame the hardware… it’s never their software. LOL


#10

Does you machine by chance have the Nvidia 680i chipset? There were problems with this particular chipset and formatting drives past 1TB in vista was one of the problems. Even if you get it partitioned, vista see’s the drive as different sizes. Disk manager see’s the full 1963.1GB size, but if you look at the drive through "My Computer, it shows as 931GB.

The solution to this is to update the Nvidia 680i chipset drivers with an update from the Nvidia site.