Beta Release - WDTV Live Plus Firmware Version 1.06.41_B (12/20/12)

WD would like to extend the opportunity to join another public beta test of the latest WD TV Live Plus firmware.  It will be available for the next two weeks.  Please post your experiences here in this thread.

To roll back, please refer to Knowledge Base Article 5800.

Very Important: Please do not rollback firmware from 1.06.41 to version 1.05.04 or earlier. Doing so may break your WDTV.

Preliminary Release Notes:

Supports iOS and Android WD TV Remote Apps.  (WD TV Remote version 1.1 Required)

Supports YouTube Leanback.

Resolved playback issues when indexing large number of files.

Resolved FLAC and OGG Vorbis files no audio output via optical connection.

Resolved unable to play ADPCM files.

Resolved MP3 audio doesn’t work in FLV video container.

Resolved music not play correctly from network share when a JPG image is in the same folder.

Resolved reboot issues when playing VCD files.

Resolved USB drive is active after eject dialog is closed.

Resolved Facebook Like/Unlike function of video option bar.

Resolved network share doesn’t filter media category for Photos.

Resolved reboot issues after hot plugging USB keyboard.

Resolved HDMI issue with certain TV models displaying a purple screen.

Resolved audio sync issue on certain .MOV container.

Resolved ISO/VOB 10 minute skip function only skips once.

Resolved momentary freeze or lag after FFW or REV video file in .VOB container.

Resolved random music playback is not random issue.

Resolved device reboot issue when playing slideshow and music from network share.

Resolved subtitles colors of subtitles and background are displayed incorrectly.

Resolved SRT subtitle outline is transparent.

Resolved IDX and SUB subtitles without end time info in header are not displayed.

Resolved file types are not filtered while browsing videos in Network Shares.

Resolved several general Flingo user interface issues.

Resolved several general Dailymotion user interface and playback issues.

Resolved video playback issue with certain MPEG2 video files.

Resolved several Pandora user interface issue.

Resolved system reboot issue when copying multiple files.

Resolved choppy playback issue with VCD video files.

Resolved HDMI video output settings being forced to unsupported resolution when setting to auto.

1 Like

HEADS UP!

 

Someone mentioned in the comparable message for the WDTV Live beta test, that the links to the FW updates are reversed.  This message’s link leads to the “V” version (intended for a Live unit), and the other FW link in the message for the Live directs us to the “B” version (which is for this Live Plus). 

 

Abstain from updating firmware until we hear from Bill or another WD support person as to “what’s up.”

 

In addition, Bill’s comment in this announcement is quite disconcerting:

Very Important: Please do not rollback firmware from 1.06.41 to version 1.05.04 or earlier. Doing so may break your WDTV.

 

1)   I continue to use 1.05.04 as it is the most stable FW for my Live Plus.

2)   If I were to participate in this beta and do not find the new FW satisfactory,  I CANNOT roll back to my preferred FW.   This is unacceptable.  So, to the invite to beta test:  Thanks, but no thanks!  I prefer NOT to brick my two units.

 

Furthermore, this consistantly bungled FW upgrade process for the Live and Live Plus is a classic example of “If it ain’t broke, don’t fix it.”  Every FW upgrade past 1.05.04 fits this description.  At this point, I likely will never upgrade past 1.05.04 even if or when this newer one is declared “ready to roll”.  Who needs the hassle?  It appears the FW has been overly tweaked at this point by so many different programmers and is likely beyond repair.

 

What I want to know, BILL, is how to prevent my Live Plus from ever wanting to auto-upgrade?  I never want to chance getting an upgrade I do not want.  This actually happened to me as recently as a few weeks ago when after successfully dodging the upgrades for over a year, my finger slipped off the tiny remote button in the wrong direction when I was going to click “Cancel” and I accidentally was into the upgrade to v1.06.16_B.  Rather than stop the process once it began, I let it all finish and then rolled back.  Whew.  It sounds like someday soon, this will not be an option anymore.

 

If upgrading to newest firmware and rolling back bricks units, WD will be replacing LOTS of Live and Live Plus units, because most WD owners don’t come into this forum, and have no idea of what can happen.  Remember how many “first time callers” came here last month when the FW disaster hit?  Plenty.

 

This is all an unfortunate situation, to be sure.

So, if you want to Rollback, you may get a “Brick” for Christmas ?   Well done WD.

You may not have read this in the original post because it is in yellow but it is extremely important.

Very Important: Please do not rollback firmware from 1.06.41 to version 1.05.04 or earlier. Doing so may break your WDTV

To keep it from auto updating by mistake, either set an ACL in your router to deny the IP of your WD Live+ from going to the WD support site - there’s an older thread in here that details it.  Since my router won’t allow ACLs, I set the gateway address in the WD Live+ setup to 127.0.0.1 - this keeps it from going out to the internet.  However, if you use Netflix or other internet services, this isn’t a good option.

With this release there will be no ‘auto updating’ as you have to download and install via a computer.

can you pleae use a diffeerent color! so that i can read it! please!!!

dougv99 wrote:

can you pleae use a diffeerent color! so that i can read it! please!!!

DITTO!  In keeping with the WD firmware updates – this website was not fully tested before springing it on us.

THE OLD WEBSITE WAS FULLY AND COMPLETELY READABLE, VIA IE AND CHROME BROWSERS AND THIS IS NOT!  Return to original format, ASAP, please.

FYI, in a typical home setting with low light (for computer viewing and to not disturb others) this new design format lights up the room like a CHRISTMAS TREE. 

thank you i had to highlight to be able to read it. i know of the the change of skin and i figured the color s were to be ok. so i’m very sorry if i sounded bad!

fhall1 wrote:

To keep it from auto updating by mistake, either set an ACL in your router to deny the IP of your WD Live+ from going to the WD support site - there’s an older thread in here that details it.  Since my router won’t allow ACLs, I set the gateway address in the WD Live+ setup to 127.0.0.1 - this keeps it from going out to the internet.  However, if you use Netflix or other internet services, this isn’t a good option.

I use the Internet services, so basically there ISN’T any good option.  What we need is a firmware to prevent the WD from ever looking for firmware updates!   :confounded:

Overall, it seems to run very smoothly.  Works well with the Android Remote.  The Network shares showed up and easily connected.  Playback looked and sounded good with HDMI /12 Bit Color Depth & Dolby Surround Sound Passthrough.  Fastforward & Rewind worked very well to - an improvement from past Firmware.

Pandora and Flickr worked flawlessly and quicker then in the past.  Netflix will not work.  The Interface loads and works well.  However, no matter what you select to playback, it gives you a, “We’re having trouble playing this title right now.  Please try again later or select a different title.”  aip-702

Down Flashed to 6.15 - Netflix works.  Reflashed to 6.41 - Netflix still works.  Must have been a glitch in the previous firmware.

Are either of these updates  Firmware Version 1.06.41_V or 1.06.41_B compatible with my WD TV Live Plus HD (WDBABX0000NBK this is an older media player)? It is currently running 1.06.34_b. This update has caused problems with my ability to network with my PC. If compatible will the new update correct the networking problem?

THanks

One flaw that is somewhat of a pain.  In the Audio/Video Settings under Audio Output - 3 Settings - Stereo, Digital through Optical and Digital through HDMI.

Previous firmware allowed for Digital Audio to flow through the HDMI while continuing to transmit Stereo on the Analog Output of the WDTV player.  This is very useful when using a Zoned Amplifier that broadcasts Audio throughout a residence or business.  

With this new firmware, you can either be HDMI or Stereo, no in between.  Need to revert this to allow the Stereo to continue to flow over the analog.  Otherwise a user will need to change the setting based on if they are watching movies or streaming music via a seperate amp.

Overall, I like the speed of this new interface.

You can always roll back if it doesn’t work.  I am using the older version of the WDTV Live Plus.  When I originally loaded the new firmware, I had problems with my network shares and had to perform a Reset to Factory Defaults in the settings. This cleared the issue up and I have no problems.

LCox23 wrote:

You can always roll back if it doesn’t work.  I am using the older version of the WDTV Live Plus.  When I originally loaded the new firmware, I had problems with my network shares and had to perform a Reset to Factory Defaults in the settings. This cleared the issue up and I have no problems.

Very Important: Please do not rollback firmware from 1.06.41 to version 1.05.04 or earlier. Doing so may break your WDTV.

Is the new Firmware Version 1.06.41_B compatible with my WD TV Live Plus (model # WDBABX0000NBK )?

Will it correct the networking  problem I’ve been have with Version 1.06.34_B ?

THanks

nikisi wrote:

Is the new Firmware Version 1.06.41_B compatible with my WD TV Live Plus (model # WDBABX0000NBK )?

Will it correct the networking  problem I’ve been have with Version 1.06.34_B ?

 

THanks

Yes.  The “_B” is for a Live Plus (the “_V” is for a Live).

WIll it fix your network problem? Dunno.  It cannot “fix” a network issue created by an improperly configured network setup.  Also, there is no way I will be a beta tester of this firmware – I do not want to brick my WD.  Did you read all the disclaimers?

Flashed to this version from the last beta, no issues to report as of yet. Everything is responsive. Previous network glitches have not occured. Did not have to reset the box for unresponsiveness so far either.

Thanks, BILL , for providing us a list of what’s been updated.