Best Way to Transfer Large Folder from Public Share to a Private Share?

I have a ton of files in my Public Share. 371GBs. I tried to drag from one share to another but it was only going at 500KB/s.

The transfers are taking place on the same hard drive. There *has* to be a faster way, right?

Right?!

How are you connected? Wireless?

A short term solution might be to connect the drive directly into your ethernet port on you computer and doing the transfer that way, then reconnecting to your network.

Tony

Yeah I’m connected wirelessly. I really hope ethernet isn’t the best route. :-/

the problem is that you are using windows to do the transfers, so the file copies are going through windows api and all the data has to be transfered back and forth from the My Book Live. I was only proposing a short term solution to get the files moved quicker.

You might want to look at your wireless connection. That seems slow. Are you on wireless N?

login via ssh and then use cp (the linux copy)

I found the mv command and that worked. Thanks!

even better

What does ssh and then use cp mean?

I suggest to google those terms a little. Use “ssh, linux” or “cp, linux”. It will help to understand your box much better.

I am looking at pulling the trigger on MyBookLive 2T tomorrow. I have 1T + of data to transfer from a passport and from my laptop. So just to confirm, I can hard wire the drive to my laptop and do the transfer of data that way for my initially and this should be faster than doing it through the network?

Thanks for your help.

Shawn

No. The topic was just about moving data within the box from one point to another.

If you transfer data to and from the box I would suggest to use FTP (Filezilla).

Or you could use rsync through ssh to transfer data from one location to the other. This way, you can turn off your PC and go elsewhere, the MBL will handle it while you are away.

This is the solution I use. During the night, one of my MBL replicates (sync) itself on the other, through a secure connexion.

The short answer is no, you can’t wire the internal hard drive to a computer to transfer data. That was my plan too, so I happily took the drive out of the enclosure, connected it up to a debian system, and discovered I can’t mount it. For some reason WD choose to use ext4 with a 64kB block size. It’s presumably possible to mount it using a custom kernel, but the stock one flatly refuses to.

If you reformat the drive to ext3, or to ext4 with a less unusual block size, then copying data to it over sata will be no problem at all. If you want to leave the current partition untouched, then you’re going to have to recompile the kernel on your desktop. I spent a while trying to find out about mounting a 64kB blocksize partition, and just found hundreds of identical posts by one guy who was benchmarking compact flash cards and thought he’d spam the internet about his problems.

I don’t see why it’d be worth the risk to do any of that.

The I/O performance of the MBL is quite good across the network.   I can get close to 250 Megabits per second on reads and writes.

WRITEPERF.PNG

30 mbyte/s is indeed good for a NAS, but it’s not the same as the 90ish you can get over sata. My motivation was that I don’t have a gigabit switch so was capped at 10 mbyte/s, and three days to fill the drive is a long time compared to the 6 hours you can get with a local connection.

Patience is certainly a far easier approach, and won’t remove the warranty.