BerryBoot fails to start PiDrive OS

Yesterday I did a sudo apt-get update and sudo apt-get upgrade on my Raspian OS (running on Pi3 and the 1TB PiDrive) and afterwards I rebooted it. Now it stays on the rainbow screen.

I did the same (couple of minutes before) on a Raspian OS running on Pi2 and a 1TB PiDrive, and it works flawless.

How can I recreate a working SD card and boot my installed OS again?

A little update. I tried to recreate a working SD card by installing Raspian with BerryBoot on an USB drive instead of reinstalling Raspian on the PiDrive. After installation it work perfect.
But again after a update and upgrade, the Pi3 fails to start. Thinking of a bug in the latest Raspian…?!

Hi, Berryboot does not use the same OS update mechanisms as the standard version of the OS. Berryboot-compatible OS files are created for specific OS releases and loaded into the download repository. Periodically, Berryboot’s author will convert updated OS versions to Berryboot format and upload them to the repository. This might explain your issue, though I haven’t tried the steps you took.

Another way to install Raspbian (and some other OSes) on PiDrive that’s come up recently is to use the latest release of NOOBS (v2.4) at the raspberrypi.org download page (https://www.raspberrypi.org/downloads/noobs/). We worked with the RPi team to implement “USB drive awareness”, providing the option to install NOOBS OSes on an attached USB drive (previously NOOBS only installed to SDcard). This is a major change- many more OSes can be installed and they can have a lot more space for data.

Thanks.

Hi, I contacted the developer of Berryboot on this and he recommends updating Berryboot prior to doing apt-get update/upgrade:

Can prevent the problem from happening by updating Berryboot itself to
the latest version (by going to the Berryboot menu editor -> “add OS” ->
accept self-update when prompted) prior to running apt-get dist-upgrade.

If the system is already bricked, just reinstall Berryboot to SD card,
and choose “use existing files” during installation.
It will patch it up to an usable state.

Hope this helps. Thanks.

Thanks for your answers and tips.

Meanwhile I managed to get a working Pi again by reinstalling Raspbian once more on the USB drive and not updating it. I removed the USB drive and connected the PiDrive again and booted the Pi. It worked fine! I got the message (when the desktop was shown) that the system was updated.

So… you say, update BerryBoot with existing files and it should work when I want to update Raspbian?
One thing learned though, create a backup of your SD card before every update :slight_smile: