Before you RMA your Device ... let's talk about your problems!

wow, the CS rep didn’t even offer to replace the drive.

Is your My Cloud still under warranty? If not then it should be no surprise that WD won’t replace the drive for free. Have you started an online case yet?

Note the following links are all found on the WD Support website under Warranty & Returns.

http://support.wdc.com/Warranty/warrantyPolicy.aspx

http://support.wdc.com/Warranty/dataRecovery.aspx

Product Replacement (RMA): https://westerndigital.secure.force.com/ind/

When dealing with any customer service a lot depends on what you tell or say to the CS drone. Often they are reading from a script. Getting angry or frustrated with them doesn’t help even through its understandable. If they sense your anger/frustration they may simply get you off the phone as soon as possible and move on to the next caller. (Edit to add: Having unrealistic expectations and then demanding the CS drone adhere to those unrealistic expectations is another sure fire way to get hustled off the call as quick as possible.) Many times one has to request to be kicked up to the next level of support.

1 Like

of course I started an online case. That’s how I started the engagement with WDC CS. I write very well and was very clear in the description. I cannot attest to CS rep reading comprehension or language skills. all I know is I did my part.

I just bought the device and it was working great. Later that day I got the notice there was a firmware update to 2.21.126. I can now only connect using the web (I am on a MAC running 10.12.3). I can manually put in the ip address to connect. I get the pop up asking for either user credentials or guest. With either choice I get a notice “Check the server name or IP address, and then try again. If you continue to have problems, contact your system administrator.” While I have not spent a lot of time trouble shooting, I just bought the device and based on the reports I am seeing about problems keeping the device connected on a MAC I will be returning the device.

I NEED HELP…

No really…

Some time ago i purchased a WD Mycloud 2 TB backup in the hopes of keeping all of my media from iPhone pictures and memories, to PC backups, to US Government paperwork safe and secure in the event that my laptop became compromised.

After setting up the MyCloud and using all of the what seemed 100s download software and tools I still cannot get my PC to recognize that my cloud device is connected.

I have tried resetting and rebooting the drive several times, ensuring that i installed the correct drivers, done troubleshooting via WD Support website, used the command prompt suggestion and the administrative tools suggestion to see if my Anti-virus was actively blocking the backup drivers from functioning properly… I even consulted YouTube to watch a few videos of how others were doing it to see if they ran into the same problem. I even went so far as to do a system reset on the device ( That which factory resets the device settings and not the media on the device) LITERALLY NOTHING seems to be able to make the WD SmartWare app able to see that my MyCloud is available to back up files from my PC to.

The only place that i can back up to is Dropbox. Now downloading and uploading on other devices seem to work just fine, I can use my iphone or log in remotely however my home PC is giving me issues.

i have attached a screenshot of the WD SmartWare for reference I currently run Windows 10

Because your using Windows 10 you may want to take a read through the following discussion which details how to adjust certain Windows 10 settings that may be preventing access to the My Cloud on the local network. These include enabling NetBIOS over TCP/IP, ensuring the network is configured for Private.

https://community.wd.com/t/compilation-of-windows-10-methods-steps-and-solutions/142576

I have several issues with my new MyCloud Mirror. The most important one is that of permissions, of the shares created. But first, my setup: Mac computers connected to a 1GB switch, on which the MC is also connected. After going through the hassle of upgrading the firmware, I created a 2-disk RAID 1 array, on which I created two shares. Those two shares are NOT public (I have created a user, with password, to access them), and I want to use them as afp shares only. I do not care for httpd, I do not care for iTunes or Time Machine backup, or Cloud Access, or smb, all I want is the afpd to do its job.

My main issue right now, is that both my shares (although NOT public) they got permissions 777, which for a NAS which will live on public internet, is completely irrational. I have edited the permissions for the shares, but unfortunately, every file copied on the shares from my Mac disks get the 777 permissions. I even tried to edit /etc/afp.conf file to set the file permissions to 750 and directory permissions to 750, but for some reason the afp.conf file gets overwritten, whenever you reboot the NAS.

So, if someone can help me, in clearing up all those processes that run in this darn thing and set up afp to maintain the permissions of the transferred file (or even assign safe permissions to the files, like 750 or 700) I would really appreciate it. I can work with Linux, just not this particular version on this NAS, I am used to Centos though.

System description: WD MyCloudMirror with firmware 2.11.164

You may want to see the dedicated My Cloud Mirror subforum and either post there or search through there (using the forum search feature - magnifying glass icon upper right) to see if there are other discussions on issues similar to yours. This subforum (My Cloud) generally is for the single bay/single drive My Cloud units.

https://community.wd.com/c/personal-cloud-storage/wd-my-cloud-mirror

Oooops, my bad, apologies are in order!

Hello everyone! First time user of WD MyCloud and just set up the hard drive and MyCloud.

We should have two users - myself and my wife. For simplicity’s sake, lets call myself USER1 and my wife USER2.

I am logged in as myself (the admin) but the only locations I see are USER2 and PUBLIC. Shouldn’t I also see a location for myself (USER1)?

I try to create a user for myself (USER1) but I get a notification saying it already exists (which it does, I get that). But I’d like to get this set up where my wife (USER2) has a location for all her files, including her computer and phone back-ups and I have a folder for myself (USER1) where I would keep my files, computer and phone back-ups.

I feel like I could be missing something simple? Any help would be appreciated. Thanks in advance!

If you haven’t done so already you should read through the My Cloud User Manual (http://support.wdc.com/product.aspx?ID=904) paying particular attention to Chapter 6 Managing Users and Chapter 7 Managing Shares. Also see the My Cloud Dashboard embedded Help which gives brief explanations on Users and Shares.

Generally when a User is created a Share (or folder if you will) is also created for that user. Generally when a Share is created it is set to Public and anyone who can access the My Cloud can access that Share and any contents/data within it. On the Shares page of the Dashboard one can configure a Share for Private, then assign User level access (Full Access, Read Access, No Access) to that Share (and by extension all of the contents of that Share).

More information on the My Cloud and answers to various questions can be found at the My Cloud Support site.

http://support.wdc.com/product.aspx?ID=904

Additional information including a few videos can be found at the My Cloud Learning Center.

http://mycloud.com/learn/?id=mycloud

One can access the contents of the My Cloud by using Windows File Explorer or Mac Finder. Again this is explained in the My Cloud User Manual. To make things easier one can “map” the My Cloud Share to their computer.

http://support.wdc.com/knowledgebase/answer.aspx?ID=2676

http://support.wdc.com/knowledgebase/answer.aspx?ID=2686

1 Like

Hi I am finding this piece of hardware incredibly frustrating and the support even more so. I have finally after 48 hours set up an account (last thing I did was activate this via an email link telling me to create my password (which I thought I had already done when I originally had access to the Dashboard). As soon as I did this I lost access to the dashboard - why cannot you access this via the normal log in route (probably far to easy!!). I have tried to follow the support to do this and it is useless i.e. I have copied and pasted the link / tried the IP address etc. and just keep going around in circles. When trying to get support from the company I get asked for the serial number pf the device (which I took from the asset tag) and then get told this is invalid. This is
the worst piece of kit I have ever had the misfortune of buying, however now I have bought it any help would be gratefully received!!

If you’re within your return period, take it back. The security holes alone make this product too much of a risk.

I thought mapping the drive might work - but can’t find the device when going though map device via computers,

This WD Cloud has been a waste of $$$ for me. It is only a year old and has barely been used at all. Shame b/c I was high on WD products and the thought of having 4 TB of reliable space available for backups and media. I will look to other makers for a more reliable solution. Symptom: No blue light except briefly after resetting followed by an error message saying something to the effect that you are screwed cuz you can’t access your cloud drive. I guess my only resolution is to remove the drive from its beautiful case and see if I can salvage anything off of the drive. If it’s a software related problem, thank you to the qualified writers of such junk. I may have lost a few hundred $$$ on this but I will make sure I tell others how reliable this product has been for me.

1 Like

What is the “exact” error message? What is the My Cloud connected to? Who is your broadband provider? What other troubleshooting steps have you tried? Does the My Cloud work if connected direct to your computer’s networking/Ethernet port? When the front doesn’t turn blue what color does it turn?

We don’t care. We’re users, not WD.

If you want to ask us for help, you’ll need to be more precise about the nature of your problem.

No lights at all on the front except after resetting. That’s short-lived then it goes out. Comcast/Xfinity is the ISP. Arris modem Tm822R hooked into a Linksys AC5400 Tri Band Wireless Router. My cloud was hooked directly into the router. At the back of the my cloud it appears to be polling as the lights are blinking where the Ethernet cable is attached. I would have to hook back up to see the exact msg again.

With the My Cloud connected to the router, does the router issue an IP address to the My Cloud? Can you ping that IP address? If SSH was previously enabled on the My Cloud can you SSH into the My Cloud? Were any unofficial modifications done to the My Cloud firmware using SSH in the past?

I will try to work on it more tomorrow after work. Car maintenance tonight. I appreciate your help…