Basics My Cloud

Hello to all,

I’m pretty new here. I am trying to let the MyCloud function, and everything seems ok, except for the connection with the PC. I use Windows XP, SP3.

During the first installation, I got some message like" Installation was not completely successful, you will not be able to see the folders, update," or some other stuff.

Questions for you “non newbies”:

  1. I find not one, but two network connections in Network resources : identical in everything, behaviour included. Is this normal?

  2. If I try to open \WDMyCloud\public, I receive error.

  3. If I try to create a drive linked to WDMyCoud I seem to go through, but the PC then asks me for some username and psw. I tried every combination, but could not satisfy its request.

Anyway, I successfully installed the WD Quick View, and can manage the Dashboard with no issue.

Can you give me some helpful advice?

Thanks a lot


On your router, what IP address has been assigned to your MyCloud?  should be somthing like 

Find this IP address.

Then in Windows Explorer under Computer, go Map Network Drive

put in \\public  where you use the correct IP address instead of the example i gave.

that should set up the link for you. After it connects, you can select it and right click and create a shortcut on your desktop.  this is the easiest way to access the drive.

If you can, set up a static IP address in teh Dashboard so that in case of reboot the IP adress does not change (dynamic means it will change).

Hi wdlive,

thanks a lot.

Unfortunately, I still get the same issue: it asks me for a username and password, which I really don’t know how to get! See image attached…

just click OK… See what happens. I’ve had this happen to me before. I assume that your public folder has is accessable to all right?  That is how you set up the permissions in the Dashboard right?  If so, then just click OK and ignore the request for USER and PWRD.  You might have to click OK a few times.

Also  disconnect all the mounted drives you have with the WD in Windows Explorer Computet. Then reboot your PC. Then remount the drive and then jus tclick OK to ignore.   You’ve got some kind fo residual thing going on with Windows. it’s not a problem with the WD

Hi I had a similar issue. try the following

/in dash board select user

/goto shares select share-make private

/give full access to user

/enter and confirm password

/when attempting to open share enter user name and password you used above

Hello to both and thanks,

still no luck. I tried both your tricks but none worked.

It keeps asking me for a password and - in mgrankin’s case - it does not recognize the ones I set up in the Dashboard.

I am thinking something is wrong with my PC.

Does anyone else have an idea?

It is really frustrating…:cry:

Thanks again


Does your PC have a User Name and Login?  Perhaps that is what it is looking for.

Have you tried it with a different PC?

Perhaps you can try to create a new user on your PC ( a different Login ID).  Then try to connect.

Hello wdlive76, and thanks again for your help.

Sadly, also this method didn’t work. What had given me few chances is that when asked for a username, if I only type the PC username, it adds my WD network name, with \ before it.

For example, if I type “edo”, it immediately changes it into “WDEdo\edo”. Therefore, I assume it really asks for a WD network user and psw, not my PC’s one.

I am however still blocked.


Anyone has other ingenious ideas?



Try removing all previous network connections. To do so:

Restart computer just to be fresh.  Open command prompt, type:  net use * /delete

type: y  when prompted and try connecting to Public.  Also, just to make it easier on everyone, can you post screenshot of your user and shares dashboard setting? 

Hi tnynyn,

tried doing as you say but the pc answered “No entries in the list” (or something similar, I’m translating from Italian).

I tried reconnecting again, always with the same results.

In attachment screenshots required, hoping they might be helpful to anyone…



ok so when you get the security popup for username/password in Windows, did you try using the username:  admin  and leave password blank?

Hello tnynyn,

yes, I tried unsuccessfully. I tried more or less 100 different combination. This issue is getting me MAD!

One important question: the only method I managed to get access to my folders, so far, is through WD MyCloud software, see image:

Through the software, I can well upload, delete, etc and all stuff.

The question is: should I find really no solution for the network disk letter assignment, would I really be missing some basic function if I only used WDMycloud software?

I mean:  I can live with the unconfort of having to open the software everytime, but not with a slower down/upload speed.

Could you comment on this?



Yes the software is fine, there wont be any speed difference as long as its on the same remote.  But I would prefer to fix the issue at hand instead of workaround, just how I am.  I have an XP box, I’ll play around with it and see if I can get the same issue as you.

Hello, I had the same issue at first.  Your problem is you have not set a password for your WD My Cloud user (admin).  In your screenshots of your \User\ tab, the only user listed is “admin” and the Password is “Off”.  You will need to create a user account and set up a password, or do what I did and edit the admin account (I changed the username from admin to my pc’s username) and then turned on Password and set up the password.  These are the credentials being asked for when you are mapping the drive.

From your screenshot It doesn’t appear as though you have any Private shares.  I’d suggest doing the following:

  • Edit the admin user to have a password for your admin account

  • Create a private share, and make sure you give your user account full access

  • log out of the Dashboard and clear all Cache, History, and Offline storage

  • If you do have any mapped connections to the MYCloud (say to the public share), disconnect then.

  • Reboot the PC

  • Open Windows Explorer and try to map a drive to your newly created private share, and enter your MyCloud username and password

  • If this works, then map a drive to your public share.  I don’t believe you’ll be asked for credentials at this point.

Hello bwarecs,

unfortunately I did as you said (the advice is not too dissimilar to what I had tried after the first contributions) but no. No change. This password - whatever it is - is really killing me.:mansad:

when you launch the browser to log into the Dashboard now, are you required to enter a password?

Yes, it asks me the password which works fine. However, the map network procedure doesn’t accept it.

:laughing:YES!!! I solved it!!!

Wandering, hopeless and clueless on the net, I stumbled upon a microsoft article who told me to activate a component (computer browser) in the service console of XP. It came out that this component was not present.

Again searching on the net, I figured out that my Client for Microsoft Networks was simply not installed.

A few clicks in Network properties, and (unbelievable after 3 weeks of mad searching) the mapping went through at once!

Thanks for the support to all…technically you might not have helped me, but the knowledge of someone caring for me was the propeller I needed.

Love you all!