BAD series of WD40EFRX drives

Hi everyone, some times ago I have bought about 20 pieces of 4 TB WD Red hard drive, at least 6 of them never worked, unfortunately I start using the disk and since I did not need them all immediately, I put all the fault ones in the drawer and I forgot them for a long time.
When I took them back the warranty was expired, but I tryed to understand what happened.
I wrote a couple of email I make all the required test, and at the end I got an answer like 'You can ask for a free replacement". I tried but since the warranty time was gone I was not able to go further in the RMA process.
A couple of days ago I took one disk I supposed to be good, I tried to initialize and instead of 4 TB the disk shows 2 TB (1678.02 GB) both with Windows, Linux, Diskstation o.s. In theory I could use the disk as that was the right capacity, but I do not trust the disk, you can imagine what happened when I use those disk in a RAID 1 system when they ‘pretend’ to be a 4 TB disk!
Did any one else encountered the same problem?
Does any one has any suggestion?