Bad HDD? Caviar Black 2TB

I have posted this same issue in Gigabyte forums and was told that it’s a HDD issue and that I need to post my issue here. So here it goes.

In August I put together my own computer. Following is my configuration for the same:-

  • GA-890FXA-UD5 (rev 2.0)
  • AMD 1090T Black Edition
  • Noctua NH-D14 CPU cooler
  • 2 x (OCZ OCZ3G1333LV8GK Gold 8GB PC10666 DDR3 Dual Channel Memory 1333MHz, Non-ECC, Unbuffered, 2x4096MB)
  • Sabrent 802.11n Wireless PCI Controller Card - 802.11n/g/b, 300Mbps
  • Plextor PX-880SA DVD/CD Super Multi Writer DVD+RW, SATA, Lightscribe
  • Kingwin LAZER 750W Power Supply - 750-Watt, 80 plus
  • HIS H545HS1G Radeon HD 5450 Silence Video Card - 1024MB DDR2
  • 2 x (Western Digital Caviar Black WD2001FASS 2TB SATA 7200rpm 64MB HDD)
  • 3 x (Noctua NF-S12B FLX fans)

I partitioned my primary HDD in 2, a 500GB Windows partition (C:) and 1.5 TB data partition D:. The second HDD had only one 2TB partition (E:) on it. I installed Windows 7 (Pro) 64-bit on it with all the latest drivers/bios available on 08/14/2010.

This build has been working fine (with a few caveats) until about 1 month back. Everyday more than 10 times Windows would report that the system fan was not working and that I should shut down the computer immediately. I opened the computer to look at the CPU cooler fans and other fans, but never saw any problems. 

Another problem I have had often is that even though the computer would recognize a wireless connection, it would not connect to it even after providing the right password and extremely high signal strength (I kept the wireless router right next to the computer). This problem started happening a few days after the build and continued until about middle of November.

I thought I’ll look into these more during my Christmas break.

Around end of November, I shut-down the computer using Windows shutdown button. Then, 2 days ago I tried turning it On, but it always gives me an error message saying Windows failed to start. Run startup repair. I disconnected the HDD which had E: and tried using the startup repair feature of Windows 7 DVD, but to no avail. 

The motherboard does not show any error messages while booting up and the HDD seems to be working fine. I took it out of the system, attached it to an external HDD enclosure and connected it to my laptop. The drive is recognized without issues and I can access all the data on both the partitions without issues.

It says C: is ‘System Reserved’.

I have tried re-installing Windows 7, but the problem is that Windows no longer recognizes C:!!! It says that the original E: is now D: and that Windows is installed on E: and that F: is 1.5TB partition. 

I have even tried swapping the SATA ports on the Mother board and formatting the whole HDD, but C: is no longer recognized and all the order of the drives/partitions seems to be messed up!

Can someone please help me understand what is going on and how can I resolve this issue?

Thanks in advance for all your time and help.

Did you got any help with this issue?

That’s odd.  I just bought the same drive in January, and have been having an extraordinary time trying to install WIN7 in my new system.  Now it doesn’t even recognize the frive.  I’m hooking it up to another system to see if it shows there.  It didn’t when plugged into my Black Ice docking station.

Looks like RMA time.