Bad file system connectivity after power failure


#1

My MyBook was working fine until last night there was a power failure. When the power came back on  so did the MyBook, but when trying to access it from Windows, the file system was extremely slow – like, 5-10 minutes to open a folder.  Then, the files in that folder were visible with Explorer, with sizes and modification dates, etc, but trying to open the files came back with unknown format or permission denied from the applications.

However, I CAN PUTTY/SSH to the MyBook from the PC’s, and then all the files are there, cd’ing into directories works fine, and the text files I cat are all fine.

I’ve tried rebooting the drive several times, unmounting the drive from my PC’s, upgrading the WD Discovery software, etc, to no avail.

I assume something happened to the file system, but I can’t figure it out, or how to repair it.  Any suggestions?

Thanks, Paul


#2

I’ve got the same problem twice over here.

I’ve got a power failure at home like some months ago. Then, I could see but barely access folders through a computer. I started to panic a little and started to backup folders through network because the “copy manager” was not copying files on USB HDD. It was transferring at like between 20-500 kb/s. Can you imagine copying even 1 gig at that speed …

In the meanwhile, I started to try to disable all the options in the web interface, even the SSH trick with mionet and twonky without success. I noticed that the white light was going up and down all the time, even with no ethernet cable connected, but not in the normal way. Habitually, the light goes up&down continuously when busy. But this time, it goes one time up and down then it flashes and goes over again.  It looks like something is keeping the processor unusually busy.

Something interesting happened. When I was rebooting the drive, it was looking like it was not working with the power button so I was always disconnecting the power cable then reconnect. But, sometime, I held the power button for 4 sec, nothing happened but someone called me in the meanwhile so I didn’t disconnected the power cable. When I came back many minutes later, I realised that the drive was off. I powered it up and it magically came up as usual working flawlessly !!!

But now, I’ve got another power failure this week and the drive is doing same thing again. This time, even if I shut it down with the power button, it still the same.

However, I am now testing all kind of options to get it work. Tell me if my first solution has worked with you. Else, I’ll keep you in touch if I find anything to make it work back.


#3

So ? How things are going on your side ?

For me, things have gone from bad to nightmare. As I created a new thread, I now can no more access the Public folder. Only the Download folder shows up. But it still display 327gig used. So the device seems to know that there still data on it.

And the other bad thing is I tried to connect a USB hard drive to copy (without success) but I accidently hot-disconnected it … so now it’s formatted. It was my storage drive for my apps, ISOs, savegames, some camera footage and some PCs old backups.

So at this time, I have lost almost all my storage (NAS + USB HDD) …

How can I still like computers after that  ?  :)