Backups Failing again

Hi All,

I had problems with my first WD My Book and had a replacement sent - thanks for that.

But now I am having the same problem - Backups failing, after making a new folder for the backups when I received the new machine (as the original TimeMachine folder was giving me the same issues - of failing) everything has been fine for the past 2 weeks until today - First thing when I wake up the iMac I see a message ‘Backup Failed’ so open the drive by its ip: to see this message:

31184 - Error retrieving firmware upgrade information: The operation was aborted while the server was processing the request. The operation may or may not have been completed successfully. Please refresh the page and try again.

The thing is I have ‘Auto Update’ disabled - and ‘Power save’ disabled so it shouldnt be trying to update the firmware !

I am on the latest firmware:

MyBookLive 02.43.03-022 : Core F/W

Using OSX 10.9.3 Maverics.

The Drive is connected via ethernet.

I have set a static IP and internet connection is ‘Good’.

This is the exact same problem I was having before - I was having to power off the drive and let it boot again before things would go back to normal - I also did a full factory reset on the old drive which didnt repair it.

I am putting the Mac to Sleep during the night which has caused no problems until today.

Hoping I can find an answer here as the point of this drive os for storing files and of course backups - I find myself trying to repair the drive before I can do any work, its annoying to say the least.

Edit: as I am sitting here the drive just tried to update the Firmware again - and failed !

Hi NikGrey, sorry to hear you are having the same problem again. Have you tried to contact tech support directly, I’m sure they can help you find the cause of the problem.